Bug 61676 - Profiling doesn't work on Linux/UNIX when spaces are in path
Profiling doesn't work on Linux/UNIX when spaces are in path
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Hurka
issues@profiler
: SPACE_IN_PATH
: 75877 125809 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-02 16:08 UTC by Jiri Sedlacek
Modified: 2009-01-12 15:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Sedlacek 2005-08-02 16:08:21 UTC
On UNIXes there can be spaces in path similar to Windows. Currently the 
Profiler is not tested for this case.
Comment 1 Jiri Sedlacek 2005-11-29 12:23:42 UTC
Profiling in environment with spaces in path doesn't work on Linux and Solaris.
Steps to reproduce on Linux:

1/ Install NetBeans to /opt/netbeans 5.0
2/ Run NetBeans with userdir /opt/netbeans 5.0 userdir
   - export NB_USERDIR="/opt/netbeans 5.0 userdir"
   - "/opt/netbeans 5.0/bin/netbeans" -userdir '$NB_USERDIR'
3/ Create new project AnagramGame in /opt/netbeans 5.0 userdir/AnagramGame
4/ Run the project, this works fine
5/ Try to profile project, it fails with this message at the app console:

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xb7b16446, pid=10799, tid=3086842784
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_05-b05 mixed mode)
# Problematic frame:
# V  [libjvm.so+0x2a2446]
#
# An error report file with more information is saved as hs_err_pid10799.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#
Agent_OnLoad called...
Agent_OnLoad completed successfully.
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Profiler Agent: native bind failed to lookup
com.sun.tools.profiler.server.ProfilerRuntime class!!!
Exception Exception Exception Exception Exception Exception Exception Exception
Exception Exception Exception Exception Exception Exception Exception Exception
Exception Exception Exception Exception Exception Exception 
Java Result: 134
Comment 2 Jiri Sedlacek 2005-11-29 12:29:34 UTC
Changing to defect and setting low priority to reflect that spaces in path are
not commonly used on Linux/UNIX.
Comment 3 dkkopp 2006-05-08 14:30:08 UTC
*** Issue 75877 has been marked as a duplicate of this issue. ***
Comment 4 dkkopp 2006-05-08 14:34:53 UTC
I had filed issue 75877 because this bug screwed me over on OS X. I install 
NetBeans multiple times with different names and user directories to make it 
easier for me to work on different projects. Right now, I have the following 
installations on my machine:

NetBeans
NetBeans 5.5 JDOCSHELL
NetBeans 5.5 Q2
NetBeans powerLOG-J

I installed the NetBeans 6.0 QBuild as NetBeans 6.0
Then I wondered why the profiler wouldn't work. After I found out about this 
bug, I installed NetBeans 6.0 as NetBeans6. That made the profiler work.

Please fix this bug. It is not something that can simply be ignored.
Comment 5 Tomas Hurka 2007-01-08 10:53:03 UTC
It works fine in latest dev builds. 
Comment 6 J Bachorik 2008-03-29 12:58:25 UTC
*** Issue 125809 has been marked as a duplicate of this issue. ***
Comment 7 Rashid Urusov 2009-01-12 15:29:51 UTC
VERIFIED in build 200901120201


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo