Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 60733 - Plugin restarts server each time it performs the deployment
Plugin restarts server each time it performs the deployment
Status: CLOSED DUPLICATE of bug 56910
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 8
4.x
All All
: P1 (vote)
: 4.x
Assigned To: issues@serverplugins
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-04 15:57 UTC by Alexander Kouznetsov
Modified: 2006-07-12 16:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2005-07-04 15:57:49 UTC
NetBeans build 200505031930
Sun Java System Application Server Platform Edition 8.1_02 (build b06-fcs) installed from Buzz 10 build

Steps to reproduce:
- add App Server
- try to run or deploy something to it at least twice
- RESULT: Server restarts each time the deployment is performed.
Comment 1 Alexander Kouznetsov 2005-07-04 16:00:42 UTC
This blocks the ability of a plugin to perform remote deployment and this blocks performance testing. See also CR 6288125
Comment 2 Vince Kraemer 2005-07-05 02:15:44 UTC
Do you have a sample project that you can attach to this issue...

I have not been able to reproduce this issue using an app  that includes a web
app that calls an ejb...
Comment 3 Vince Kraemer 2005-07-05 07:04:06 UTC
Please attach log data from the output window when you deploy or run the project
that exhibits this behavior, too.
Comment 4 Petr Blaha 2005-07-05 16:17:27 UTC
mrkam, can you attach output from verifier also? We had encountered restart
server issue in case when EJB module had some errors.
Comment 5 Vince Kraemer 2005-07-05 17:13:21 UTC

*** This issue has been marked as a duplicate of 56910 ***
Comment 6 Vince Kraemer 2005-07-05 17:17:54 UTC
Please validate the closure, by reading throught the other issue.  If this issue
has a different root casue, please re-open it with enough detail to reproduce
the error.
Comment 7 Alexander Kouznetsov 2005-07-06 10:07:52 UTC
It seems that this is not the duplicate, because the issue was reproducible with any application, specifically blank newly created Web Application, EJB Modules and J2EE Applications with minimal modifications. Unfortunately, although I've reproduced the issue with the configuration specified, I can't reproduce it now and need some additional time to find the root cause. As soon as I found it I will update the report.
Comment 8 Vince Kraemer 2005-07-06 17:28:58 UTC
A filer is not responsible for discovering the root cause.  I was asking you to
confirm that you are not encountering the same bug. If your steps to reproduce
this issue don't involve the same issue, the assigned engineer will determine
what the root cause is. You need to provide enough information for the engineer
assigned to fix the bug to be able to reproduce it.
Comment 9 Vince Kraemer 2005-07-06 18:44:09 UTC
I just did a test with 4.1 and 8.1 update 2.

If I deploy an ejb module that is the root cause of issue 56910, the server will
restart on the next deploy of ANY module (regardless of whether that module has
errors or not).

This may contribute to the behavior you are reporting.  
Comment 10 Vince Kraemer 2005-07-20 23:57:00 UTC
new / duplicate

*** This issue has been marked as a duplicate of 56910 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo