Bug 59749 - "Apply Code Changes" throws NullPointerException
"Apply Code Changes" throws NullPointerException
Status: CLOSED DUPLICATE of bug 58323
Product: debugger
Classification: Unclassified
Component: Java
4.x
PC Windows XP
: P4 (vote)
: 5.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-08 16:39 UTC by mariso
Modified: 2010-04-29 09:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (17.69 KB, text/plain)
2005-06-08 16:40 UTC, mariso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mariso 2005-06-08 16:39:37 UTC
"Apply Code Changes" doesn't work for me. I am using SUN AS 8.1.

When I press the button it always throws NPE:

Classes to be reloaded:
 lv.idega.txgateway.wstestclient.wsclient.WSClient
D:\Projects\IdegaTransactionGateway\TransactionGatewayWEBTestClient\nbproject\build-impl.xml:461:
The following error occurred while executing this line:
D:\Projects\IdegaTransactionGateway\TransactionGatewayWEBTestClient\nbproject\build-impl.xml:209:
java.lang.NullPointerException
BUILD FAILED (total time: 2 seconds)

It refers to "nbjpdareload" in those lines:

    <target name="-do-debug-fix" if="netbeans.home"
depends="init,-pre-debug-fix,compile-single">
        <webproject1:nbjpdareload/>
    </target>


        <macrodef name="nbjpdareload"
uri="http://www.netbeans.org/ns/web-project/1">
            <attribute name="dir" default="${build.classes.dir.real}"/>
            <sequential>
                <nbjpdareload>
                    <fileset dir="@{dir}" includes="${fix.includes}*.class"/>
                </nbjpdareload>
            </sequential>
        </macrodef>


Steps to reproduce: 
-run IDE 
-create a new WEB app with a WEB Service client
-start debug session with SUN AS 8.1 PE (sun-appserver-pe8.1_01)
-add some line of code (for example add "int t=0;").
-press "Apply code changes"
Comment 1 mariso 2005-06-08 16:40:29 UTC
Created attachment 22558 [details]
messages.log
Comment 2 Martin Entlicher 2005-06-08 20:30:51 UTC
This seems to be a duplicate of issue #58323 (see also issue #58396). It's
already fixed in 4.2 dev builds.

*** This issue has been marked as a duplicate of 58323 ***
Comment 3 Quality Engineering 2010-04-29 09:23:08 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo