Bug 58949 - Important Files are not CVS annotated
Important Files are not CVS annotated
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
5.x
All All
: P4 (vote)
: 5.x
Assigned To: Martin Krauskopf
issues@apisupport
jihlava
: UI
Depends on:
Blocks: 57776
  Show dependency treegraph
 
Reported: 2005-05-16 15:08 UTC by _ pkuzel
Modified: 2005-11-22 15:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Sshot (12.51 KB, image/png)
2005-05-17 15:59 UTC, _ pkuzel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2005-05-16 15:08:39 UTC
In Project view there are
  Module Manifest
  Arhitecture Description
  ...
files without CVS statuses consistently visualized (become green on local
modification). Note that respective nodes contain CVS actions. 

Expected behaviour: all nodes that somehow represent file(s) must consult
FileSystem.[Html]Status to let it annotate name, htmlName and icon.
Comment 1 Jesse Glick 2005-05-16 17:31:49 UTC
Icon is I guess already badged.
Comment 2 _ pkuzel 2005-05-17 09:02:36 UTC
File icons are not CVS badged (compare to containers/folders). So users do not
notice actual file status until they inspect Files view or Versioning view.

P3, it's rather visible and users are very sensitive to proper status visualization.
Comment 3 _ pkuzel 2005-05-17 09:40:18 UTC
Moreover Important Files (LogicalViev.ImportantFilesNode) container is ackward too. 

Because it does correspond to physical folder it must take FileSystem for any
file it contains and ask the FileSystem to annotate its icon, name and htmlName
passing own inital icon, name, htmlName and Set of all contained files. 
Comment 4 Jesse Glick 2005-05-17 14:51:10 UTC
I have an NBM project (check out from CVS) open right now and the file badging
under Important Files works fine, I don't know what you're talking about. Please
attach a screenshot and build info if you see otherwise.

Will not put any CVS status on the Important Files node itself. It has no
correspondence to any physical structure; it just would not make sense to
annotate it.
Comment 5 _ pkuzel 2005-05-17 15:56:12 UTC
New CVS does not annotate single file icons. You can not see any. It annotates
file's htmlName only.

Logical containers should be annotated too. It gets barged once at least one
file in container has conflict or is locally modified.
Comment 6 _ pkuzel 2005-05-17 15:59:00 UTC
Created attachment 22165 [details]
Sshot
Comment 7 Jesse Glick 2005-05-17 18:46:57 UTC
I guess you're talking about upcoming changes not yet in the trunk?

Can badge Important Files if you really think it should be. Just sounds odd to
me, because it's not a natural file unit the way a source group is, and it's
showing files which also appear in other places (just in a more convenient
location).
Comment 8 _ pkuzel 2005-05-18 09:12:48 UTC
Yes, I mean upcoming changes not yet in the trunk.

Comment 9 _ pkuzel 2005-05-30 16:01:06 UTC
Partially implemented for Important Files (firing is not reliable). 
Need to be implemented for subnodes.
Comment 10 Jesse Glick 2005-09-07 21:28:47 UTC
Martin do you have time for it?
Comment 11 Martin Krauskopf 2005-09-20 14:02:37 UTC
New code, could be interesting. So yes, I will :)
Comment 12 Martin Krauskopf 2005-09-20 15:14:13 UTC
Implemented for subnodes.

Checking in ui/ModuleLogicalView.java; 1.11 --> 1.12

Petre, what did you mean by: "Partially implemented for Important Files"? Are
you working on this? "Important Files" icon is still not badget.
Comment 13 Martin Krauskopf 2005-11-09 14:15:43 UTC
Ok. If nothing closing. All seems to work now including Important Files.
Comment 14 Jesse Glick 2005-11-10 00:55:43 UTC
XML Layer does not - issue #68240.
Comment 15 Tomas Danek 2005-11-22 15:29:08 UTC
badged, colored. Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo