Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 58498 - JSPs not shown in web freeform
JSPs not shown in web freeform
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Web Freeform
4.x
All All
: P2 (vote)
: 5.x
Assigned To: Petr Pisl
issues@javaee
http://www.netbeans.org/servlets/Read...
release41_fixes_fixed
: RELNOTE
: 60891 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-02 17:39 UTC by zikmund
Modified: 2006-03-24 12:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2005-05-02 17:39:12 UTC
Build 200504291131 (4.1 RC2)
Based on user feedback (see URL) on nbusers mailing list.

Scenario A:
A1) Create Web freeform (using wizard Web Application with Existing Ant Script)
and press Finish in 5th panel! (Don't go to the next panels)
A2) Explore Web Pages
A3) ERROR:
no any JSP files are shown.

Scenario B:
B1) Have a web freeform with empty Web Pages classpath
B2) Restart IDE
B3) Open project's Properties | Web Sources
B4) Change context path/J2EE specification level, press OK
B5) Explore Web Pages
B6) ERROR:
no any JSP files are shown.

Workaround is:
W1) Open project's Properties
W2) Go to Web Sources Classpath panel
W3) Press OK
W4) Restart IDE
Comment 1 Petr Pisl 2005-05-02 18:08:32 UTC
I have fix for this. The problem is, that there is not the <classpath /> element
in the project.xml file in certain cases. 
Comment 2 Petr Pisl 2005-05-03 09:49:31 UTC
Fixed in the trunk
/cvs/web/freeform/src/org/netbeans/modules/web/freeform/WebModules.java,v  <-- 
WebModules.java
new revision: 1.6; previous revision: 1.5
Comment 3 zikmund 2005-05-25 14:17:50 UTC
Verified in 200505250639.
Comment 4 zikmund 2005-05-25 14:17:57 UTC
Verified in 200505250639.
Comment 5 zikmund 2005-07-12 18:15:37 UTC
*** Issue 60891 has been marked as a duplicate of this issue. ***
Comment 6 zikmund 2005-07-12 18:35:04 UTC
original problem from nbusers (thread continues):
  http://www.netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=52252
Comment 7 zikmund 2005-07-13 10:36:44 UTC
Duplicate from nbusers:
  http://www.netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=55504


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo