Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 58230 - [41cat] 4.0 web project cannot use Test Package
[41cat] 4.0 web project cannot use Test Package
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
4.x
All All
: P2 (vote)
: 5.x
Assigned To: Radko Najman
issues@javaee
: RELNOTE
: 57732 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-22 15:28 UTC by zikmund
Modified: 2006-03-24 13:03 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2005-04-22 15:28:11 UTC
Build 200504211930

1) Open 4.0 Web Project
2) Resolve all broken references (Includes Upgrading project)
Note:
  see nbproject/project.properties values:
    build.test.classes.dir=
    build.test.results.dir=
    javac.test.classpath=
    run.test.classpath=
  SHOULD BE:
    build.test.classes.dir=${build.dir}/test/classes
    build.test.results.dir=${build.dir}/test/results
    debug.test.classpath=${run.test.classpath}
    javac.test.classpath=\
      ${javac.classpath}:\
      ${build.classes.dir}:\
      ${libs.junit.classpath}
    run.test.classpath=\
      ${javac.test.classpath}:\
      ${build.test.classes.dir}
3) Create test directory
4) Create test for a class
5) Test WebApp
6) ERROR

Workaround is: create Web Application with Existing Sources.
Comment 1 mdm42 2005-04-25 10:43:56 UTC
*** Issue 57732 has been marked as a duplicate of this issue. ***
Comment 2 zikmund 2005-04-25 10:47:17 UTC
Found by NetCAT 4.2 participant (mdm42).
Comment 3 Radko Najman 2005-04-25 17:43:54 UTC
Accepted.
Comment 4 zikmund 2005-04-26 12:00:19 UTC
Should be part of 4.1 Release Notes together with issue 58231.
Comment 5 Radko Najman 2005-04-26 16:01:55 UTC
Fixed.

/cvs/web/project/src/org/netbeans/modules/web/project/UpdateHelper.java,v  <-- 
UpdateHelper.java
new revision: 1.18; previous revision: 1.17
Comment 6 zikmund 2005-05-25 15:30:15 UTC
Verified in 200505250639.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo