Bug 57644 - Provide wizard for Explorer TopComponent
Provide wizard for Explorer TopComponent
Status: RESOLVED DUPLICATE of bug 20851
Product: apisupport
Classification: Unclassified
Component: Templates
4.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
: API
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-07 23:34 UTC by santhosh
Modified: 2011-11-09 16:25 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
My ExplorerPanel implementation (3.50 KB, text/plain)
2005-04-07 23:34 UTC, santhosh
Details
Standalone ExplorerPanel Implementation (3.76 KB, text/plain)
2005-04-10 21:35 UTC, santhosh
Details
one more contribution: Cloneable ExplorerPanel implementation (3.55 KB, text/plain)
2005-04-10 21:39 UTC, santhosh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description santhosh 2005-04-07 23:34:03 UTC
the class ExplorerPanel is deprecated. now we need to extend TopComponent and do
lot of coding (implement Explorer.Provider)
it nearly takes 90 lines of code to create My own ExplorerPanel.
why don't you create one such class in openide. 
now wherever used needs ExplorerPanel, he has to replicate the same code. 
irritating. 

to make my job easier I created My own ExplorerPanel without using any
deprecated api called XExplorerPanel.

I am contributing my class to netbeans. 
plz add this to Openide and make beginners life easier.
Comment 1 santhosh 2005-04-07 23:34:40 UTC
Created attachment 21476 [details]
My ExplorerPanel implementation
Comment 2 santhosh 2005-04-07 23:38:42 UTC
the attached class also takes care of finding HelpCtx from selected nodes.
Comment 3 santhosh 2005-04-07 23:47:16 UTC
if you don't want to replace ExplorerPanel, you may add this class as it is to
openide and specify in javadoc to use XExplorerPanel rather than ExplorerPanel.
Comment 4 David Simonek 2005-04-08 14:17:41 UTC
passing to explorer guys.
Comment 5 Petr Nejedly 2005-04-08 14:20:27 UTC
Agreed but it is an enhancement request.

Comment 6 santhosh 2005-04-10 21:35:57 UTC
Created attachment 21525 [details]
Standalone ExplorerPanel Implementation
Comment 7 santhosh 2005-04-10 21:38:16 UTC
one more contribution.

i attached one more file Explorer.java
 this is a standalone explorer panel implementation
 (i.e, extending JPanel instead of TopComponent)
Comment 8 santhosh 2005-04-10 21:39:50 UTC
Created attachment 21526 [details]
one more contribution: Cloneable ExplorerPanel implementation
Comment 9 Petr Nejedly 2005-06-15 10:39:12 UTC
Note: I can't directly use your code in openide-explorer module as it still
extends a TopComponent from openide-windows module, which is unwanted dependency.
The original ExplorerPanel was deprecated just because of that dependency, to
allow openide split. Anyway, I'd like to provide some helper even without
openide-windows dependency.
Comment 10 Antonin Nebuzelsky 2008-02-07 16:11:55 UTC
Reassigning to new module owner Tomas Holy.
Comment 11 Jesse Glick 2011-11-09 16:25:16 UTC

*** This bug has been marked as a duplicate of bug 20851 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo