Bug 57543 - Can't run applet with parameters in directory with space
Can't run applet with parameters in directory with space
Status: CLOSED FIXED
Product: java
Classification: Unclassified
Component: Project
4.x
All All
: P2 (vote)
: 4.x
Assigned To: Tomas Zezula
issues@java
jdk_bug_6193279
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-06 14:07 UTC by zikmund
Modified: 2006-03-24 12:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2005-04-06 14:07:56 UTC
Build 200504051800

1) Create Java library in derectory with space
2) Create JApplet
3) Create JApplet's HTML launcher (by running JApplet as single Run)
4) Copy HTML launcher from build directory besides applet
5) Run applet
6) ERROR:
I/O Exception in Output window appears. Applet is not started.
Comment 1 zikmund 2005-04-06 14:30:34 UTC
JDK 1.5.0_03
Same for Debug Applet.

See issue 51253 where same problem was workarounded for JDK 1.5.0 and 1.5.0_01.
Comment 2 zikmund 2005-04-06 14:35:15 UTC
It's problem in j2seproject - see original issue 51253 for more information
about workaround for JDK 1.5 AppletViewer jdk_bug_6193279.
Comment 3 zikmund 2005-04-06 15:14:25 UTC
It fails also with in JDK 1.5.0-b64-fcs on Linux & Windows - seems to be a
regression.
Comment 4 Tomas Zezula 2005-04-06 17:14:22 UTC
It's not regresion it didn't work in NetBeans 4.0 too, but it should be fixed.
It is related to the issue #51253. The generateHTML() works fine but the
copyHTML() is broken. It should be fixed in the same way as the generateHTML().
Comment 5 Tomas Zezula 2005-04-07 12:17:01 UTC
Checking in
j2seproject/src/org/netbeans/modules/java/j2seproject/J2SEActionProvider.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/J2SEActionProvider.java,v
 <--  J2SEActionProvider.java
new revision: 1.42; previous revision: 1.41
done
Checking in
j2seproject/src/org/netbeans/modules/java/j2seproject/applet/AppletSupport.java;
/cvs/java/j2seproject/src/org/netbeans/modules/java/j2seproject/applet/AppletSupport.java,v
 <--  AppletSupport.java
new revision: 1.9; previous revision: 1.8
done
Comment 7 zikmund 2005-04-07 16:42:26 UTC
Verified in continuous build 20050407-1254 (JDK 1.5.0_03, WinXP).

Go for release41 integration from QE.
Comment 8 Martin Grebac 2005-04-08 10:24:25 UTC
The fix is ok.
Comment 9 Andrei Badea 2005-04-08 10:39:54 UTC
The fix looks ok to me.
Comment 11 zikmund 2005-04-15 18:20:26 UTC
Verified in 4.1 build 200504142205.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo