Bug 57282 - App Server is not installed on 64bit JDK on Linux/AMD64
App Server is not installed on 64bit JDK on Linux/AMD64
Status: RESOLVED WONTFIX
Product: installer
Classification: Unclassified
Component: Tools bundle
4.x
Other Linux
: P3 (vote)
: 6.x
Assigned To: mslama
issues@installer
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-31 18:48 UTC by jvincent
Modified: 2006-03-08 09:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Installation log file. (36.39 KB, text/plain)
2005-03-31 18:49 UTC, jvincent
Details
Current NetBeans messages.log file. (217.03 KB, text/plain)
2005-04-07 17:21 UTC, jvincent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jvincent 2005-03-31 18:48:50 UTC
I am trying to run/install NetBeans 4.1 Beta on SuSE 9.2-64 (AMD 64 3400+).  

Some specifics I noticed:

- Sun App Server 8.1 install fails
- Netbeans startup scripts are not marked executable (wrong permissions).
- Install summary screen points me to log file <nbhome>/_uninst/as-install.log 
that doesn't exist.

Netbeans 4.1ea2 worked fine.  I am attaching the install.log.  I see a couple 
of ServiceExceptions that I assume is because I am doing a user install:

ServiceException: (error code = 305; message = "isCurrentUserAdmin requires 
platform pack support. "; severity = 0) 

and a couple of NullPointerExceptions that I can't interpret.
Comment 1 jvincent 2005-03-31 18:49:27 UTC
Created attachment 21273 [details]
Installation log file.
Comment 2 mslama 2005-04-01 07:54:58 UTC
Please use 32bit JDK for installer. You can use command line switch -is:javahome
<path to JDK>. We do not test/support installer on 64bit JDK.
1.Problem with missing executable permissions is known. It is problem of
InstallShield. See issue #49621.
Comment 3 mslama 2005-04-04 14:45:26 UTC
What JDK do you use? I will check remaining issues with JDK 1.5.0_02 if I can do
anything with it.
Comment 4 mslama 2005-04-04 16:17:05 UTC
1.ServiceException can be fixed by adding platform pack support for Generic UNIX.
2.NPE is fixed is this code was recently rewritten. But root cause is that AS
installer we run silently at background does not run on 64bit JDK => AS cannot
be installed using 64bit JDK. (Please I do not say AS itself will not RUN on
64bit JDK. I talk about AS installer only.)

So with permission problem the only workaround available now is to run asbundle
installer on 32bit JDK. After installation you should be able to run IDE and/or
AS on 64bit JDK.
Comment 5 jvincent 2005-04-04 16:17:29 UTC
Currently I'm using JDK 1.4.2_06.  

Will the NB4.1 installer eventually support the 64-bit platforms?  Why does 
the installer work differently from the 32-bit systems?  Is it not Java-
based?  Does it run on Solaris (64-bit)?
Comment 6 mslama 2005-04-05 16:18:30 UTC
I just found that when running installer on 64bit Linux + AMD 64 + 64bit JDK
(Linux 2.4.21-20.ELsmp #1 SMP Wed Sep 15 20:03:51 EDT 2004 x86_64 x86_64 x86_64
GNU/Linux) InstallShield does not detect Linux as it does with 32bit JDK on the
same OS/machine but it detects Generic UNIX.

I also found that os.arch returned by 64bit JDK is amd64  but 32bit JDK returns
i386.

When I add platform support for Generic UNIX NB installer works also on 64bit
JDK. So it fixes issue #49621. Please see this issue for more details if you are
interested.

To answer your questions: I am going to fix issue #49621 in trunk - dev builds.
It is too late to commit it for NB 4.1 release. It will be fixed in next
release. Installer uses some OS specific code and it requires some OS specific
support. Yes installer is based on Java. Regarding 64bit JDK for Solaris - it is
installed together with 32bit JDK for Solaris. I just tested with 64bit JDK and
there is some problem with it. I will investigate it and file separate issue.

Even if this is fixed AS installer itself does not run on Linux/AMD 64bit JDK so
asbundle installer cannot install AS.
Comment 7 jvincent 2005-04-07 17:21:27 UTC
Created attachment 21464 [details]
Current NetBeans messages.log file.
Comment 8 jvincent 2005-04-07 17:22:24 UTC
Ignore the messages.log file...
Comment 9 mslama 2005-04-08 15:16:00 UTC
Conclusion: Our installer problem is fixed as issue #49621. We will also handle
problem of AS installer as issue #57469. We will show warning and do not allow
user to continue. 

I will leave this issue opened to track AS installer. If AS installer will run
on 64bit JDK we can remove check implemented as fix of #57469.
Comment 10 mslama 2005-06-09 13:18:35 UTC
I filed issue #6263398 to Bugster against SJS AS.
Comment 11 mslama 2006-03-08 09:19:36 UTC
According to info from AS team AS9 will not support 64bit on Linux. Closing as
WONTFIX.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo