Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 54652 - Cannot remove parameter from method signature
Cannot remove parameter from method signature
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Refactoring
4.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: Ralph Ruijs
issues@java
:
: 53146 (view as bug list)
Depends on:
Blocks: 65780
  Show dependency treegraph
 
Reported: 2005-02-08 09:21 UTC by _ rkubacki
Modified: 2011-06-06 12:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2005-02-08 09:21:58 UTC
dev build of 4.1 from Feb 7, JDK 5.0u1

there is a refactoring called change method
signature but it does not allow me to remove
existing method parameter.
Comment 1 Martin Matula 2005-02-08 09:29:21 UTC
It does allow you to remove the parameter. But only if it is not used.
This is as designed - if we allow to remove used parameters, we would
not know how to refactor the code to make it compilable. People would
then file issues that the refactoring breaks their code. We can
consider this as an enhancement request (probably if we display a
warning that a given parameter is used, removal could be fine).
Comment 2 _ rkubacki 2005-02-08 09:36:54 UTC
Now I see. 
Comment 3 Ralph Ruijs 2011-05-23 12:31:15 UTC
Warning was added in:
46114:0fc688ea33f5 - Jun 12, 2007
Comment 4 Ralph Ruijs 2011-06-06 12:32:52 UTC
*** Bug 53146 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo