Bug 54467 - Remove implementation dependency on db modules
Remove implementation dependency on db modules
Status: RESOLVED WONTFIX
Product: db
Classification: Unclassified
Component: Code
4.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Libor Fischmeistr
issues@db
TCR
: API
Depends on:
Blocks: 52155
  Show dependency treegraph
 
Reported: 2005-02-03 13:37 UTC by Jaroslav Tulach
Modified: 2016-05-25 06:17 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2005-02-03 13:37:40 UTC
Intercluster implementation dependencies have to
be prohibited, so please remove those on db modules.
Comment 1 Pavel Buzek 2005-02-03 16:55:10 UTC
Cannot be solved in 4.1 because db module has no public API.
Although it is used only in enterprise cluster the assumption is that
some modules in ide cluster will want to use it in future so we do not
want to move db modules into enterprise cluster (although that would
solve the immediate problem).

I will ask for 4.1 waiver as soon as 4.0_WAIVER_REQUEST keyword is
created.

In promo-F we have to figure out how to solve this. We can publish the
de facto db API as it is now if we do not plan to do any major work on
it. If we do (and we probably should) we will provide a replacement
for the current private API.
Comment 2 Pavel Buzek 2005-02-10 09:19:03 UTC
DevRev agreed this can be downgraded to P2.
Comment 3 Petr Jiricka 2005-02-24 19:13:58 UTC
Partially improved by moving the db/model (dbschema) module to
enterprise1 cluster. This does not remove any implementation
dependencies, but it eliminated a cross-cluster implementation
dependency on dbschema.

Comment 4 Petr Jiricka 2005-03-04 10:41:28 UTC
Waiver for NetBeans 4.1 approved.
Comment 5 Pavel Buzek 2005-08-04 04:46:18 UTC
Andrei is working on new db explorer API, that will solve the db module.
The dbschema will be solved by creating a friend API that will be used only
within enterprise cluster (see also issue 54471).
Comment 6 Andrei Badea 2005-08-18 09:47:33 UTC
The friend API for dbschema was integrated into the trunk yesterday.
Comment 7 Petr Jiricka 2005-08-25 08:55:27 UTC
Well, I would say this is still not completely fixed, because there is an
implementation dependency of dbschema on db, which can not be eliminated by the
use of the new evolving API in db. This dependency also goes across clusters
(enterprise2 to ide6). Still, the major part of this was fixed, so reopening
with P3 priority.
Comment 8 Petr Jiricka 2005-08-25 09:20:19 UTC
This last subitem depends on the ability to have both public (evolving) and
friend API in one module, discussed as a part of issue 54123.
Comment 9 Jaroslav Tulach 2005-08-25 13:39:22 UTC
If the impl dep is between "really close" modules[1], then it is relatively 
ok. I mean - it is not excelent, but we know no better right now. No need to 
keep an open issue for that until we found what problems it causes. 
 
[1] close modules must be in the same cluster, should be developed by the same 
guys, always build together, the bridge should the thin and externally 
unvisible 
 
Comment 10 Andrei Badea 2005-09-06 08:22:17 UTC
db and dbschema don't match Yarda's definition of "really close" (they are not
in the same cluster). The impl dep is mainly caused by the usage of libddl part
of the db module in order to retrieve the database structure. Another way to
remove it (apart from the one Petr mentions) could be to make use of the new
database model (as soon as it's ready) instead of libddl.
Comment 11 Petr Blaha 2006-03-13 13:47:30 UTC
TM 5.0 -> TBD
Comment 12 Andrei Badea 2006-05-25 14:51:59 UTC
Not doable for 5.5 I think.
Comment 13 Andrei Badea 2007-07-09 10:21:47 UTC
Not for 6.0 either.
Comment 14 David Vancouvering 2008-11-12 17:33:29 UTC
We are working on a new metadata model, but currently it's read-only.  Perhaps it can be used to replace libddl in the
next release, let's give it a shot.
Comment 15 Jiri Rechtacek 2009-02-10 15:13:00 UTC
Reassigned to new owner.
Comment 16 Jiri Rechtacek 2009-10-16 14:08:11 UTC
Reassigned to new owner.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo