Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 53843 - New line before else and catch
New line before else and catch
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
4.x
PC All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 06:41 UTC by kovica
Modified: 2016-07-07 07:30 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kovica 2005-01-22 06:41:46 UTC
Since issue 53334 is not being fixed I suggest
adding new opption to Java formatting engine :
"Don't add new line before else and catch words"
or something like this that would do the following
formatting:
try
{
  // code
} catch (Exception e)
{
   e.printStackTrace()
}

and

if (true)
{
  // code
} else if (true)
{
   // some more code
} else
{
   // more code
}
Comment 1 Martin Balin 2016-07-07 07:30:36 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo