Bug 52871 - Loss of KB focus from Navigator window
Loss of KB focus from Navigator window
Status: RESOLVED DUPLICATE of bug 59934
Product: java
Classification: Unclassified
Component: Navigation
4.x
PC Linux
: P2 (vote)
: 4.x
Assigned To: David Simonek
issues@java
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-03 21:54 UTC by Jesse Glick
Modified: 2005-10-17 22:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (1.89 KB, text/plain)
2005-01-03 21:54 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2005-01-03 21:54:26 UTC
Dev AU version. Not 100% sure what I did, but I
was using Navigator fine for a while with just the
keyboard. Then I saw the filter buttons, but did
not see any way to activate them via the keyboard;
I think I clicked on one of them. Anyway, after
that, I lost KB focus from the Navigator window;
there was no selection, and no keystrokes seemed
to do anything in it, incl. after pressing Escape
to slide it out and C-S-5 to slide it back in.

I can click on the list and use the arrow keys,
but if I hide the Navigator (ESC or Enter) and
reshow it, there is no KB focus again. Closing
(C-F4) and reopening the window does not help
either; I need to restart the IDE.

Looks like an exception is responsible.
Comment 1 Jesse Glick 2005-01-03 21:54:57 UTC
Created attachment 19441 [details]
Stack trace
Comment 2 Jesse Glick 2005-01-03 21:58:02 UTC
Navigator component essentially useless by keyboard. Restarting IDE
only helps first showing of component; after it has been hidden once,
the problem occurs again.

I am using JDK 1.6.0-b16.
Comment 3 Jesse Glick 2005-01-07 18:32:41 UTC
Same problem using trunk version of navigator included in the build.
Comment 4 Jesse Glick 2005-01-21 01:16:39 UTC
I can confirm that this problem only occurs when the Navigator is in
autohide mode (which IMHO is where you would want it to be, so it does
not take space from the editor). Annoying.
Comment 5 David Simonek 2005-01-21 10:59:40 UTC
Jo, I'll look at it, I understand that it's important. I'll have to
define right focus traversal cycles etc.
Comment 6 Jesse Glick 2005-01-22 00:30:27 UTC
Sorry, now that I have tried docking Navigator in non-sliding mode
(permanently visible), I still sometimes see this problem. Not sure
about the exact circumstances which trigger it.
Comment 7 David Simonek 2005-02-24 19:28:49 UTC
hopefully fixed along with 54266. Filters now accessible by regular
tab traversal. Thanks goes also to Milos, who fixed Tab traversal
behaviour across the system.
Of course please reopen with info if reappears, thx.
Comment 8 Jesse Glick 2005-04-09 16:26:20 UTC
I don't think this is fully fixed - still lose focus sometimes (not all the
time) - but I don't have time now to try to reproduce, sorry.
Comment 9 Jesse Glick 2005-10-17 22:48:56 UTC
x
Comment 10 Jesse Glick 2005-10-17 22:49:11 UTC

*** This issue has been marked as a duplicate of 59934 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo