Bug 50757 - I18N - Resource properties file encoding problem
I18N - Resource properties file encoding problem
Status: RESOLVED DUPLICATE of bug 32392
Product: utilities
Classification: Unclassified
Component: Properties
4.x
All All
: P2 (vote)
: 4.x
Assigned To: issues@utilities
issues@utilities
: I18N, UI
: 69075 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 21:08 UTC by tgeor
Modified: 2006-01-04 15:49 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tgeor 2004-10-22 21:08:02 UTC
Resource property files ignores systems file
encoding and uses always ISO-8859-1.

This is a problem because developers want to have
properties source files in the languages enconding
(e.g ISO-8859-7 for greek properties files) and
using native2assii transform this files to unicode
for the build distribution.
Comment 1 Marian Petras 2004-10-25 09:17:34 UTC
This is rather an enhancement than a defect. According to the
specification of routines for reading and writing of properties,
.properties files are always saved using ISO-8859-1.

We will try to implement this enhancement.
Comment 2 Marian Petras 2005-11-29 17:33:30 UTC
*** Issue 69075 has been marked as a duplicate of this issue. ***
Comment 3 rcasha 2005-12-03 05:31:30 UTC
If the properties file is opened using "Open", then any non-latin1 characters
are converted to unicode sequences as in \u017C. However if it is opened using
"Edit", any such characters are lost (converted to ?). The "Edit mode" editor
should perform the same conversion.
Comment 4 Jesse Glick 2006-01-02 21:48:19 UTC
The spec forces ISO-8859-1 + escapes for the physical storage. (Alas. Would have
been far better to specify UTF-8. Too late.) But the editor could show the real
characters.

*** This issue has been marked as a duplicate of 32392 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo