Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 50559 - copyfiles task doesn't report errors
copyfiles task doesn't report errors
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Web Project
4.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: Pavel Buzek
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 14:32 UTC by zikmund
Modified: 2004-10-22 21:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2004-10-18 14:32:30 UTC
Build 200410171800

1) Have a file locked by other program (e.g. with
noshare attribute)
2) Try to overwrite this file by 'copyfiles' ant
task (used for copying libraries to WEB-INF/lib on
build)
3) ERROR:
There should be an error message that the file
couldn't be rewritten. Now it doesn't report any
problem.
Comment 1 Pavel Buzek 2004-10-22 21:09:28 UTC
This is not a bug. The <copy> task does not report any errors either.
When we switch to copy task in 4.1 (hopefully) you will not get any
error. The failonerror parameter of copy task is true by default so
this is not considered to be an error.

(Our copyfiles actually delegates to copy internally; I also created a
simple ant file and tested... see for yourself if you do not believe:-)

If you still believe there should be some warning message shown to the
user file and enhancement and I will try to figure our how to do it in
ant.

<project name="foo" default="test">
<target name="test">
    <taskdef
classpath="E:\\nb_all\\nbbuild\\netbeans\\ide4\\ant\\extra\\copyfiles.jar"

            classname="org.netbeans.modules.web.project.ant.CopyFiles"
name="copyfiles"/>
  <!--  <copyfiles files="userdir.zip" todir="foo"/>-->
    <copy file="userdir.zip" todir="foo"/>
</target>
</project>


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo