Bug 49256 - On Startup Scanning Project Classpath loops continuously
On Startup Scanning Project Classpath loops continuously
Status: RESOLVED DUPLICATE of bug 47433
Product: java
Classification: Unclassified
Component: Unsupported
4.x
PC Windows ME/2000
: P1 (vote)
: 4.x
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-19 04:47 UTC by amenegat
Modified: 2007-09-26 09:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description amenegat 2004-09-19 04:47:46 UTC
I don't know how to recreate this but it seems to 
be happening more frequently.

When I start up the ide it start with "Scanning 
Project Classpath" and I get a progress bar that 
shows the progress.  After it's finished the 
dialog box closes then comes up again and this 
time it says "Initializing scanning. Please 
wait..." 

It closes then reopens continuously even if I 
leave it for hours.  No more progress bar just 
the initializing message.

What seems to fix it is if I delete 
the .netbeans\nb4.0beta1 directory

When I first ran netbeans it asked if I wanted to 
import settings from 3.6 and I said yes.  This 
time I selected no.  Hopefully that was the 
problem but it's annoying to have to delete that 
directory whenever this happens.
Comment 1 Martin Matula 2004-09-19 17:17:11 UTC
Probably caused by a partial fix to issue 48611.
Comment 2 Marian Mirilovic 2004-09-19 20:11:39 UTC
amenegat,
what build number you use ???

this is P1 issue so your answer is important, thanks in advance.
Comment 3 amenegat 2004-09-20 00:31:05 UTC
Bulid Number is 200408191352
JDk client 1.5.0-beta-b32c on win2k

(Not worth making a new issue but can the about:detail page be made 
readonly but selectable so the info above could have been copied and 
pasted?)

It happened again when I went to look for the build number.  Had to 
delete the .netbeans\nb4.0beta1 directory again so transfering 
settings from 3.6 or not doesn't seem to make a difference.

I also seem to get that initializing dialog box every so often out of 
nowhere though it is fairly infrequent.

BTW, I've been playing with the 4.0 betas and early access releases 
for some time.  I can't go back to the 3.6 ones because 4.0 is so 
much better I hope this gets worked out soon.  I even used eclipse 
for a while but came back to netbeans.  You guys are doing a great 
job.
Comment 4 Jan Chalupa 2004-09-20 08:17:05 UTC
Some confusion here. Tomas' fix of issue #48611 was put into trunk
just recently. I can't see how it could cause a bug in beta 1 which
the user is apparently using.
Comment 5 Martin Matula 2004-09-20 08:51:08 UTC
Oh, now I realize we saw this bug before and fixed it. It was a URL
problem - in some cases the apisupport project returned URL which was
not normalized (the disk letter was lowercased) on Windows which
caused equals on two URLs representing the same file to return false.
As you can see from the duplicate, this was fixed some time ago.

*** This issue has been marked as a duplicate of 47433 ***
Comment 6 amenegat 2004-09-20 16:06:31 UTC
Ok, so what do I have to do to get the fix?  Will downloading the 
file again from the beta link do it or do I have to get a more 
current snapshot, beta, nightly, qbuild?  Can I just do an update 
from the ide itself?

Just because the problems been fixed doesn't mean it fixes my 
problem :)
Comment 7 Jan Chalupa 2004-09-20 16:34:23 UTC
Either download a recent Q-build or dev build from:

http://www.netbeans.info/downloads/download.php?a=n&p=1

or wait for NB 4.0 Beta 2 (to be released soon).

You might also want to update your JDK 1.5 version. Build 32c is Beta
1. There's a release candidate available from java.sun.com.
Comment 8 Quality Engineering 2007-09-20 09:46:54 UTC
Reorganization of java component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo