Bug 49085 - Corrupted source after adding component
Corrupted source after adding component
Status: CLOSED FIXED
Product: usersguide
Classification: Unclassified
Component: Code
4.x
All All
: P1 (vote)
: 4.x
Assigned To: Petr Hrebejk
issues@usersguide
beta2-fix
:
Depends on: 41009
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-15 14:04 UTC by Milan Kubec
Modified: 2006-03-24 09:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
before adding button (10.14 KB, text/plain)
2004-09-15 14:06 UTC, Milan Kubec
Details
after adding button (10.00 KB, text/plain)
2004-09-15 14:08 UTC, Milan Kubec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2004-09-15 14:04:06 UTC
[pre-beta2 20040915, JDK 1.5.0 RC]

Steps to reproduce:
1) Create Anagram Game example project
2) Open Ahagrams.java
3) Add JButton to the panel with other buttons
Error: See source code - all impl of listeners are
gone. See attachments.
Comment 1 Milan Kubec 2004-09-15 14:06:59 UTC
Created attachment 17652 [details]
before adding button
Comment 2 Milan Kubec 2004-09-15 14:08:02 UTC
Created attachment 17653 [details]
after adding button
Comment 3 Milan Kubec 2004-09-15 14:42:12 UTC
I was told that the problem is wrong setting of 'Listener generation
Style' when creatign the example. Example must be created with default
IDE setting which is 'Annonymous Inner Classes'. Please recreate the
example.
Comment 4 Milan Kubec 2004-09-15 15:10:28 UTC
Issue must be fixed to beta2 = P1.
Comment 5 Marian Mirilovic 2004-09-15 15:23:29 UTC
P1 ???

and what if somebody had changed setting before he/she open this
project ? He/She'll file another P1 ? 

It's Form Editor bug, not usersguide !  and definitely not P1 .
Comment 6 Jan Stola 2004-09-15 15:44:42 UTC
Rollbacking Marian's changes (after discussion with him).

We agreed that the Anagram template should be regenerated
with the default value of Listener Generation Style property.
Comment 7 Milan Kubec 2004-09-15 15:57:22 UTC
It's P1 because it must be fixed into Beta2 branch ASAP (not by
definition). Indeed there is bug in form editor, but it won't be fixed
until next release, so it must be fixed in the example.
If user changes any setting, it's his/her problem not ours, but the
point is if user doesn't change anything and uses our example as base
for own playing with IDE/form editor it gets screwed up completly.
It will be really sad if provided example won't work in IDE.
Comment 8 Milan Kubec 2004-09-15 16:41:33 UTC
It seems that correct component is projects finally.
Comment 9 Petr Hrebejk 2004-09-15 16:49:45 UTC
Regenerated the forms should work now. Maybe someone should file a
nice bug against form editor? Nut I'm really not sure what they could
do about it.

(Fixed in both trunk and beta2 branch)

Checking in anagrams/src/com/toy/anagrams/ui/About.java;
/cvs/usersguide/j2seexamples/anagrams/src/com/toy/anagrams/ui/About.java,v
 <--  About.java
new revision: 1.4; previous revision: 1.3
done
Checking in anagrams/src/com/toy/anagrams/ui/Anagrams.java;
/cvs/usersguide/j2seexamples/anagrams/src/com/toy/anagrams/ui/Anagrams.java,v
 <--  Anagrams.java
new revision: 1.4; previous revision: 1.3
done
Comment 10 Jan Chalupa 2004-09-15 17:05:04 UTC
This issue is RESOLVED with no resolution flag. Reopening to resolve
properly.
Comment 11 Jan Chalupa 2004-09-15 17:05:32 UTC
Resolved fixed by phrebejk.
Comment 12 Jesse Glick 2004-09-15 17:07:35 UTC
Issue #41009 is what was referred to.
Comment 13 Milan Kubec 2004-09-21 10:44:19 UTC
Verified in pre-beta2-200409210530.
Comment 14 Milan Kubec 2004-10-01 14:31:47 UTC
Verified in custom 20041001.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo