Bug 48811 - Allow tabs to request attention (flash, etc.)
Allow tabs to request attention (flash, etc.)
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
4.x
All All
: P2 (vote)
: 4.x
Assigned To: Milos Kleint
issues@platform
corepromoe
: API, API_REVIEW_FAST
Depends on:
Blocks: 19631 49693
  Show dependency treegraph
 
Reported: 2004-09-10 00:38 UTC by _ tboudreau
Modified: 2008-12-22 19:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Implementation of "flashing" tabs on the 4.0 tab control w/ heavy unit tests; also some bug fixes found while writing the tests (81.88 KB, patch)
2004-09-10 00:39 UTC, _ tboudreau
Details | Diff
Backport of the 4.0 window system to 3.6 (test heavily if you want to use it!) (436.05 KB, application/octet-stream)
2004-09-10 03:04 UTC, _ tboudreau
Details
Blinking tab patches (improved) + integration into window system & API for 4.0 (124.39 KB, patch)
2004-09-10 19:59 UTC, _ tboudreau
Details | Diff
Window system backport to 3.6 with blinking tabs code (444.99 KB, application/octet-stream)
2004-09-10 21:38 UTC, _ tboudreau
Details
apichanges for openide (1.85 KB, patch)
2004-11-16 14:59 UTC, Milos Kleint
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2004-09-10 00:38:01 UTC
Requested by the Bow team:  Provide a way to make tabs "flash" 
or otherwise request the user to click on them, for use in 
collborative/messaging environments.
Comment 1 _ tboudreau 2004-09-10 00:39:09 UTC
Created attachment 17538 [details]
Implementation of "flashing" tabs on the 4.0 tab control w/ heavy unit tests; also some bug fixes found while writing the tests
Comment 2 _ tboudreau 2004-09-10 00:41:07 UTC
I'm tempted to integrate this, given that the "flashing" code path will not be used by 
NetBeans 4.0, and the additional tests and bug fixes (a couple off-by-one errors in the 
data model when using add/remove methods the window system doesn't normally use) are 
worthwhile.

But since it's late in the 4.0 game, this should probably wait for 4.1.
Comment 3 _ tboudreau 2004-09-10 03:04:23 UTC
Created attachment 17539 [details]
Backport of the 4.0 window system to 3.6 (test heavily if you want to use it!)
Comment 4 _ tboudreau 2004-09-10 19:59:48 UTC
Created attachment 17564 [details]
Blinking tab patches (improved) + integration into window system & API for 4.0
Comment 5 _ tboudreau 2004-09-10 20:01:49 UTC
The last patch adds the following methods to TopComponent:

public void requestAttention (boolean brief); //if brief, it will blink a few times and stop
public void cancelRequestAttention();

and the following methods to WindowManager:

protected void topComponentRequestAttention();
protected void topComponentCancelRequestAttention();

and blinking is also implemented for sliding buttons.
Comment 6 _ tboudreau 2004-09-10 21:38:11 UTC
Created attachment 17565 [details]
Window system backport to 3.6 with blinking tabs code
Comment 7 _ tboudreau 2004-09-15 10:36:47 UTC
Assigning to API reviews - might as well get a head start on this, so once the trunk is 
branched for 4.0 release, it can be committed.
Comment 8 Jaroslav Tulach 2004-09-15 12:39:26 UTC
I can confirm that this is really heavy tested. I have no comments
about the functionality, I believe that it works and I am sure that
this will be maintainable in future. 

I just want few more improvements in documentation. Please mention
this in:
1. set of usecases in
http://www.netbeans.org/download/dev/javadoc/TabbedContainerAPI/architecture-summary.html
2. set of usecases of windowsystem arch*.xml
3. create apichanges document for TabbedContainerAPI and update it
4. update window system apichanges
Comment 9 _ tboudreau 2004-09-15 13:42:51 UTC
> I just want few more improvements in documentation. Please mention
> this in...

No problem with doing that - but I've learned my lesson with including
docs patches in code patches - inevitably someone adds some other
change before the issue is committed, breaking the diff, and you have
to keep fixing the patch to keep up with arch or apichanges docs.

So no problem to do this, but if you don't mind I'd rather integrate
the code, then add the documentation.
Comment 10 Milos Kleint 2004-11-16 10:00:07 UTC
what is the status of this review? 
I assume it's approved and just waiting to be integrated. Since Tim is
no longer on the winsys/ui team, I guess I'm taking over.
Comment 11 Milos Kleint 2004-11-16 14:59:36 UTC
Created attachment 18924 [details]
apichanges for openide
Comment 12 Milos Kleint 2004-11-18 14:29:52 UTC
integrated into trunk.
increased version of openide+core/tabcontrol
added apichanges entries.
Comment 13 _ tboudreau 2004-11-19 03:06:05 UTC
Thanks for doing that, Milos - I was wondering this week if I should step in and go ahead 
and integrate this :-)
Comment 14 Jaroslav Tulach 2004-11-19 09:46:21 UTC
I would suggest to make the WindowManager methods non-abstact and
empty. It hurts nobody and makes 4.0 and 4.1 at least binary compatible.
Comment 15 Milos Kleint 2004-11-19 12:56:49 UTC
ok, it's quite unlikely that soneone would attempt to implement
his/her own window system but generaly it's ok with me to make it
non-abstract.
Comment 16 Milos Kleint 2004-11-22 09:15:53 UTC
done, Windowmanager has the new methdos as non-abstract.
Comment 17 _ tboudreau 2005-07-19 19:30:09 UTC
x


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo