Bug 48680 - Web Service Client Exception: ClassNotFoundException
Web Service Client Exception: ClassNotFoundException
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Code
4.x
Sun Solaris
: P1 (vote)
: 5.x
Assigned To: _ pcw
j2eetmp
EA1
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 14:47 UTC by Petr Blaha
Modified: 2006-05-31 18:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Client Exception (2.28 KB, text/plain)
2004-09-08 14:48 UTC, Petr Blaha
Details
NB log (13.58 KB, text/plain)
2004-09-16 10:15 UTC, Petr Blaha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2004-09-08 14:47:29 UTC
Build: 040908
How to reproduce:
1) In Runtime tab right-click on Web Services
node, select Add Webservice item
2) write
http://www.quisque.com/fr/chasses/crypto/cesar.asmx?WSDL
to URL text field
3) Get Web Service Information
4) Click on one Test Method, you get response from
web service
5) Add the web service
6) IN Runtime tab invoke same method, which you
tried on previous step. I get Service Client
Exception.
Comment 1 Petr Blaha 2004-09-08 14:48:24 UTC
Created attachment 17483 [details]
Client Exception
Comment 2 _ pcw 2004-09-16 02:03:52 UTC
In the future, please include entire stack trace (in this case, all
sequential stack traces, since this is a wrapped exception.)

I cannot reproduce this.  The class being searched for is the
generated service class which is in a jar created and saved by the
registry.  Any additional information (such as IDE was shut down and
restarted after adding service, but before invoking method) would be
helpful for diagnosis.  If this is reproducible across builds, I can
add diagnostic code that would pinpoint the problem.
Comment 3 Petr Blaha 2004-09-16 10:14:01 UTC
Build 040915,
These steps was performed with new user's dir
Steps:
1) go to runtime tab, click Web Services node, invoke Add WebService
2) on Add Web Service panel enter mentioned above WSDL URL
3) click Set HTTP Proxy button - set proxy
4) click Get Web Service Information button
5) get Web Service Information
6) click Test Method fo String cipherOne(String,int), new window is opened
7) enter the values for required parameters, click Submit button
8) get response from server, cilck Close button
9) on Add Web Service click on Add, WS is added to registry
10) double-click Web Services - Cesar - Cesar Soap - cipherOne
11) enter same values, click Submit
and get ClassNotFound Exception
Note: ClassNotFound is caused by  java.io.FileNotFoundException:
/space/NetBeans/j2ee/040915/dev/websvc/webservice1095324749952.jar (No
such file or directory), wsclient is cerated in $TEMP dir but not in
userdir, see full output. Userdir has right permissions.
Comment 4 Petr Blaha 2004-09-16 10:15:20 UTC
Created attachment 17679 [details]
NB log
Comment 5 Petr Blaha 2004-09-30 17:31:59 UTC
[Build 040930]
I reproduced this issue when add Web Service Client into web
application, however this is high important feature defined for EA1 I
increase priority to P1 
Steps:
1) create new web application with one web service
2) create second web application with web service client
3) extend Web Service Reference node and click in node representing
Web service's method
Get java.io.FileNotFoundException:
/space/NetBeans/j2ee/040930/4.0beta2/websvc/webservice1096561398030.jar
(No such file or directory) ......
Comment 6 _ pcw 2004-10-01 22:54:04 UTC
Thanks for the detailed steps.  This is bug was caused by attempting
to create the web service jar in a non-existent directory
($userdir\websvc had not been created yet for this particular sequence
of steps.)  This bug does not exist in rave because the directory is
created by their installer (at least I believe it is).  It showed up
for us when I moved the location of websvc_runtimejars.xml from
$userdir\websvc to $cluster.config.dir\WebServices.

Fix available, pending review.
Comment 7 _ pcw 2004-10-02 01:59:01 UTC
Fix reviewed by Ludo and committed.
Comment 8 Petr Blaha 2004-10-04 14:01:59 UTC
Build 041004
Comment 9 Petr Blaha 2004-10-13 10:40:16 UTC
Remove all issues from temporary component.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo