Bug 46648 - DEADLOCK: when running Internaly App which inserts into DB
DEADLOCK: when running Internaly App which inserts into DB
Status: RESOLVED INVALID
Product: db
Classification: Unclassified
Component: Code
4.x
PC Linux
: P3 (vote)
: 4.x
Assigned To: issues@db
issues@db
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 09:20 UTC by dmladek
Modified: 2004-10-11 15:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
FTD (15.99 KB, text/plain)
2004-07-28 09:21 UTC, dmladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dmladek 2004-07-28 09:20:54 UTC
Product Version       = NetBeans IDE Dev (Build
200407271830)
  Operating System      = Linux version
2.4.22-1.2115.nptl running on i386
  Java; VM; Vendor      = 1.5.0-beta3; Java
HotSpot(TM) Client VM 1.5.0-beta3-b59; Sun
Microsystems Inc.
  Java Home             = /usr/local/java/jdk1.5.0/jre
  System Locale; Encod. = cs_CZ (nb); ISO-8859-2
  Home Dir; Current Dir = /usr/local/home/delphym;
/usr/local/forte/forte3/NBdev-last/netbeans/bin
-------------------------------------------------------------------------------

I have added 3 folowing jdbc drivers:
IBM DB2(net)
Oracle9i
Oracle87

Using small Insert app I was inserting 20000000
rows into 2 tables.
I left IDE doing its job, but later I've found it
freez. I'm attaching the ThreadDump
Comment 1 dmladek 2004-07-28 09:21:18 UTC
Created attachment 16497 [details]
FTD
Comment 2 dmladek 2004-07-28 14:12:34 UTC
I don't know exactlty how it happened and I'm not able to reproduce it.
Thus downgrading to P3
Comment 3 Jesse Glick 2004-08-17 04:44:56 UTC
Should not call driver methods from EQ as they could block
indefinitely (as here, waiting for data from the network).
Comment 4 Radko Najman 2004-10-11 15:46:40 UTC
Internally running application has nothing to do with Database
Explorer. Closing as INVALID.

The problems from the attached FTD should be already fixed by previous
changes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo