Bug 45094 - UI frozen because fold updating access MDR from AWT thread
UI frozen because fold updating access MDR from AWT thread
Status: RESOLVED DUPLICATE of bug 42333
Product: editor
Classification: Unclassified
Component: Code folding
4.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@editor
issues@editor
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 13:58 UTC by _ rkubacki
Modified: 2007-11-05 13:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (22.54 KB, text/plain)
2004-06-17 13:59 UTC, _ rkubacki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2004-06-17 13:58:14 UTC
dev build from Jun17, Linux, JDK1.5.0b55

Open project, ALT-SHIFT-O, open some Java file and
the UI can become frozen for a long time because
fold updating asks for MDR data that may need to
parse large amount of sources (superclasses, ...).
Comment 1 _ rkubacki 2004-06-17 13:59:33 UTC
Created attachment 15808 [details]
thread dump
Comment 2 Martin Roskanin 2004-06-18 08:52:17 UTC
already tracked

*** This issue has been marked as a duplicate of 42333 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo