Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 43893 - Cannot remove >1 VCS mount at once
Cannot remove >1 VCS mount at once
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: vcscore
4.x
PC Linux
: P4 (vote)
: 4.x
Assigned To: Martin Entlicher
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 15:01 UTC by Jesse Glick
Modified: 2004-08-13 12:12 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch that fixes this issue. (1.20 KB, patch)
2004-05-27 18:15 UTC, Martin Entlicher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-05-26 15:01:06 UTC
Dev build. In Versioning Manager, you can select
several mounts at once. But if you click Remove,
only one is actually removed.
Comment 1 Martin Entlicher 2004-05-27 16:59:26 UTC
Well, there is set single selection model. But you're able to select
more rows via SHIFT + ARROW (but not by SHIFT + mouse).
It looks like there is a bug in TreeTableView, since with ordinary
JTable the selection works O.K.
Comment 2 Martin Entlicher 2004-05-27 18:14:03 UTC
This is a bug in TreeTableView class.
Comment 3 Martin Entlicher 2004-05-27 18:15:42 UTC
Created attachment 15328 [details]
Patch that fixes this issue.
Comment 4 Martin Entlicher 2004-05-27 18:16:28 UTC
It's necessary to propagate the selection model to the table.
Comment 5 Petr Nejedly 2004-05-28 11:41:44 UTC
"This is a bug in TreeTableView" -> OK, then set it so.
Comment 6 _ tboudreau 2004-07-22 01:04:19 UTC
Martin, I just tested your patch, and it does no harm - but it didn't make it possible to 
multi-select in the versioning manager either - I'm guessing there's something you need 
to do in your code once the patch is there?

Anyway, you have my approval to commit your patch - since I didn't have anything to test 
it with other than verifying that it doesn't hurt anything, I'm not going to do it myself.  Feel 
free to commit it & whatever the versioning manager needs whenever you want to, once it 
all works.  (possibly it not doing anything is related to Aqua L&F?)
Comment 7 Martin Entlicher 2004-07-26 10:47:11 UTC
This is actually a duplicate of issue #29534, as Tim pointed out.
I'm going to commit the patch. Thanks Tim.


*** This issue has been marked as a duplicate of 29534 ***
Comment 8 Martin Entlicher 2004-07-26 11:25:36 UTC
Well, I realized, that the main problem here was, that one should be
able to remove more then one FS at once.

The single selection was there intentionally for simplicity before
(probably because of customize action). The patch in TreeTableView
made that work correctly. However, I think that we can allow muti
selection.
Comment 9 Martin Entlicher 2004-07-26 11:33:06 UTC
Fixed in trunk. I'm not sure why I didn't do this before, this should
not be dependent on the fix of issue #29534.

/cvs/vcscore/src/org/netbeans/modules/vcscore/ui/fsmanager/Bundle.properties,v
 <--  Bundle.properties
new revision: 1.9; previous revision: 1.8

/cvs/vcscore/src/org/netbeans/modules/vcscore/ui/fsmanager/VcsManager.java,v
 <--  VcsManager.java
new revision: 1.13; previous revision: 1.12
Comment 10 Martin Entlicher 2004-07-26 11:33:31 UTC
FIXED :-)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo