Bug 43887 - AIOOBE from IntList.get
AIOOBE from IntList.get
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
4.x
PC Linux
: P3 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
:
Depends on:
Blocks: 43882
  Show dependency treegraph
 
Reported: 2004-05-26 14:20 UTC by Jesse Glick
Modified: 2008-12-22 22:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (1.21 KB, text/plain)
2004-05-26 14:21 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-05-26 14:20:48 UTC
Trunk. Don't know how to reproduce.
Comment 1 Jesse Glick 2004-05-26 14:21:36 UTC
Created attachment 15242 [details]
Stack trace
Comment 2 _ tboudreau 2004-05-28 12:23:54 UTC
Fixed.  There's a tweak in sendCaretToLine() that tries to ensure a few lines below the line 
requested are visible, which didn't check to make sure there *are* lines there to make 
visible.

Checking in src/org/netbeans/core/output2/ui/AbstractOutputPane.java;
/cvs/core/output2/src/org/netbeans/core/output2/ui/AbstractOutputPane.java,v  <--  
AbstractOutputPane.java
new revision: 1.4; previous revision: 1.3
done
Processing log script arguments...
Comment 3 Marian Mirilovic 2005-12-20 15:48:21 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo