Bug 42617 - RequestProcessor and Thread.MIN_PRIORITY tasks on Linux
RequestProcessor and Thread.MIN_PRIORITY tasks on Linux
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: issues@platform
issues@platform
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-29 17:06 UTC by _ pkuzel
Modified: 2008-12-22 14:45 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2004-04-29 17:06:36 UTC
Recalling that system solution for background
threading has been promised instead of
bin/tasklist_bgthreads library.

Problem is that Thread with MIN_PRIORITY blocks
foreground threads such as AWT. It may render IDE
on Linux to be unresponsive.

All modern desktop systems support at least two
thread levels. It simplifies application
programmer life a lot. Please enable this feature
for linux.
Comment 1 Antonin Nebuzelsky 2004-06-11 17:50:14 UTC
Do we want to implement this for promo-D?
I remember we planned to do so...
Comment 2 _ rkubacki 2004-06-14 16:11:35 UTC
There is no simple solution for NetBeans. One may want to try
-XX:+UseThreadPriorities option mentioned in
http://java.sun.com/docs/hotspot/VMOptions.html. Also there are option
-XX:-UseSpinning and -XX:PreBlockSpin=10

Personally I see some improvement in percetion of operations like
warmup on my Linux with fedora core 2 based on 2.6.5 kernel running on
JDK1.5.0 builds. I do not expect that we will change anything in
promo-D timeframe.
Comment 3 _ ttran 2004-07-06 09:16:32 UTC
not clear to me what this issue is about.  We pass thread priority
down to JVM, what more can we do?

WONTFIX
Comment 4 _ pkuzel 2004-07-07 08:40:41 UTC
RP fix (or transitive JVM fix) was mentioned by performance team at
time when NetBeans native code workarounding this problem was dropped.

Just continue pushing on proper implementation and planing teams.
Linux end users would really appreciate it.
Comment 5 _ rkubacki 2004-07-23 16:45:49 UTC
As we've discussed recently there is no plan to make any change in RP now.

We agreed that it would be usefull to measure and compare behaviour on
Linux 2.4/JDK1.4 vs. Linux 2.6/JDK1.5
Comment 6 _ pkuzel 2004-07-26 09:15:04 UTC
and vs. Windows and with the nice() workaround.
Comment 7 Jaroslav Tulach 2008-10-24 09:12:20 UTC
We've seen no problems caused by ignored thread priorities recently.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo