Bug 42240 - Deadlock during new project creation
Deadlock during new project creation
Status: RESOLVED WORKSFORME
Product: java
Classification: Unclassified
Component: Unsupported
4.x
Sun SunOS
: P1 (vote)
: 4.x
Assigned To: Tomas Zezula
issues@java
: RANDOM, THREAD
Depends on:
Blocks: 41535
  Show dependency treegraph
 
Reported: 2004-04-21 09:55 UTC by Jan Lahoda
Modified: 2007-09-26 09:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Full Thread Dump of the deadlock. (29.67 KB, text/plain)
2004-04-21 09:56 UTC, Jan Lahoda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2004-04-21 09:55:11 UTC
NB trunk build 200404191800, JDK1.4.2

A deadlock occurred during new project creation.
Attaching full thread dump. I did not changed any
values in the new project dialog, except the
location and name of the project (location:
$MY_HOME/nbprojects, project newProject8). The
project seems to be created on the disk.
Comment 1 Jan Lahoda 2004-04-21 09:56:06 UTC
Created attachment 14494 [details]
Full Thread Dump of the deadlock.
Comment 2 Jesse Glick 2004-04-22 03:34:42 UTC
From looking at the the thread dump, I think it is likely that the
changes from issue #42306 should correct it - the property being
changed should not affect the classpath. Of course more generally
there is no documented threading model for the Java parser, so who
knows what could happen in the future.

I am assuming this deadlock was not reproducible for you?
Comment 3 Jesse Glick 2004-04-22 03:37:06 UTC
Probably dupe of issue #41288.
Comment 4 Jan Lahoda 2004-04-22 09:45:29 UTC
Yes, it is not 100% reproducible, but it happens quite often on my
computer.

It really seems like duplicate of issue #41288, so closing as such.

*** This issue has been marked as a duplicate of 41288 ***
Comment 5 Tomas Zezula 2004-04-26 13:04:50 UTC
Not an exact duplicate of issues #41288.
Reopening.
Comment 6 Tomas Zezula 2004-05-05 10:50:21 UTC
Can not reproduce, reopen it if the deadlock happens again.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo