Bug 41766 - Cannot navigate with kb in the search output
Cannot navigate with kb in the search output
Status: VERIFIED FIXED
Product: utilities
Classification: Unclassified
Component: Search
3.x
PC All
: P2 (vote)
: 4.x
Assigned To: issues@utilities
issues@utilities
: A11Y, FOCUS
: 43195 (view as bug list)
Depends on: 40507
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-06 23:03 UTC by Pavel Buzek
Modified: 2005-07-19 12:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2004-04-06 23:03:40 UTC
I can switch to search results from Window menu
(or Ctrl-Shift-0) but it does not move focus
there. I want to be able to navigate thru the list
of items under "Found 2 matching nodes.".
Switching to Output window with Ctrl-4 and using
Alt-< does not transfer focus either. Once I click
into the Search Results window I can navigate
everything.
Comment 1 Marian Petras 2004-04-07 07:47:12 UTC
This bug is just a concrete example of bug #40507 ("Activating a
TopComponent does not move focus to its focus cycle").

I can provide a workaround (substituting the missing functionality of
the window system mentioned in bug 40507) but not a clear solution.
Comment 2 Marian Petras 2004-06-25 08:02:32 UTC
*** Issue 43195 has been marked as a duplicate of this issue. ***
Comment 3 Marian Petras 2004-06-25 17:49:40 UTC
Fixed in the trunk.

When the Search Results window is activated, the tree of found files
and occurences obtains focus.

Modified file:
   utilities/src/org/netbeans/modules/search/ResultView.java   (1.18)
Comment 4 Max Sauer 2005-07-19 12:27:38 UTC
in nb200507181000, the focus is changed properly, user is able to navigate
through the search results. Verifying.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo