Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 41612 - Tools/Javadoc manager throws a NullPointerException under Windows Look and Feel
Tools/Javadoc manager throws a NullPointerException under Windows Look and Feel
Status: VERIFIED WORKSFORME
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
:
Depends on: 33281
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 01:04 UTC by iamacat
Modified: 2008-12-22 18:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
My ide.log with exceptions (104.64 KB, text/plain)
2004-04-02 01:06 UTC, iamacat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description iamacat 2004-04-02 01:04:39 UTC
The stack trace is given below. There is no 
problem under Metal L&F. I am using NetBeans 3.
6rc2.

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.
invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.
invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.
invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:
324)
	at org.openide.util.actions.CallableSystemAction.
invokeAction(CallableSystemAction.java:179)
	at org.openide.util.actions.CallableSystemAction.
access$000(CallableSystemAction.java:31)
	at org.openide.util.actions.
CallableSystemAction$ActionRunnable.
doRun(CallableSystemAction.java:241)
	at org.openide.util.actions.
CallableSystemAction$2.run(CallableSystemAction.
java:111)
	at org.openide.util.Task.run(Task.java:136)
	at org.openide.util.RequestProcessor$Task.
run(RequestProcessor.java:330)
	at org.openide.util.RequestProcessor$Processor.
run(RequestProcessor.java:686)
Caused by: java.lang.NullPointerException
	at javax.swing.border.EmptyBorder.
<init>(EmptyBorder.java:54)
	at com.sun.java.swing.plaf.windows.
WindowsTableHeaderUI$XPDefaultRenderer.
getTableCellRendererComponent(WindowsTableHeaderUI.
java:63)
	at org.openide.explorer.view.TableSheetCell.
getTableCellRendererComponent(TableSheetCell.java:
227)
	at org.openide.explorer.view.
TreeTableView$SortingHeaderRenderer.
getTableCellRendererComponent(TreeTableView.java:
1158)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getHeaderRenderer(BasicTableHeaderUI.java:394)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getHeaderHeight(BasicTableHeaderUI.java:428)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
createHeaderSize(BasicTableHeaderUI.java:454)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getPreferredSize(BasicTableHeaderUI.java:485)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1275)
	at javax.swing.ViewportLayout.
preferredLayoutSize(ViewportLayout.java:75)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at javax.swing.ScrollPaneLayout.
preferredLayoutSize(ScrollPaneLayout.java:507)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at java.awt.BorderLayout.
preferredLayoutSize(BorderLayout.java:572)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at javax.swing.ScrollPaneLayout.
layoutContainer(ScrollPaneLayout.java:769)
	at java.awt.Container.layout(Container.java:1020)
	at java.awt.Container.doLayout(Container.java:
1010)
	at java.awt.Container.validateTree(Container.
java:1092)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validate(Container.java:
1067)
	at java.awt.Window.pack(Window.java:444)
	at org.netbeans.core.windows.services.
NbPresenter.initialize(NbPresenter.java:188)
	at org.netbeans.core.windows.services.
NbPresenter.<init>(NbPresenter.java:129)
	at org.netbeans.core.windows.services.NbDialog.
<init>(NbDialog.java:37)
	at org.netbeans.core.windows.services.
DialogDisplayerImpl$1.run(DialogDisplayerImpl.
java:57)
	at org.openide.util.Mutex$1.run(Mutex.java:938)
[catch] at java.awt.event.InvocationEvent.
dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.
java:454)
	at java.awt.EventDispatchThread.
pumpOneEventForHierarchy(EventDispatchThread.java:
201)
	at java.awt.EventDispatchThread.
pumpEventsForHierarchy(EventDispatchThread.java:
151)
	at java.awt.EventDispatchThread.
pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.
pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.
run(EventDispatchThread.java:100)
==>
java.lang.NullPointerException
	at javax.swing.border.EmptyBorder.
<init>(EmptyBorder.java:54)
	at com.sun.java.swing.plaf.windows.
WindowsTableHeaderUI$XPDefaultRenderer.
getTableCellRendererComponent(WindowsTableHeaderUI.
java:63)
	at org.openide.explorer.view.TableSheetCell.
getTableCellRendererComponent(TableSheetCell.java:
227)
	at org.openide.explorer.view.
TreeTableView$SortingHeaderRenderer.
getTableCellRendererComponent(TreeTableView.java:
1158)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getHeaderRenderer(BasicTableHeaderUI.java:394)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getHeaderHeight(BasicTableHeaderUI.java:428)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
createHeaderSize(BasicTableHeaderUI.java:454)
	at javax.swing.plaf.basic.BasicTableHeaderUI.
getPreferredSize(BasicTableHeaderUI.java:485)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1275)
	at javax.swing.ViewportLayout.
preferredLayoutSize(ViewportLayout.java:75)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at javax.swing.ScrollPaneLayout.
preferredLayoutSize(ScrollPaneLayout.java:507)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at java.awt.BorderLayout.
preferredLayoutSize(BorderLayout.java:572)
	at java.awt.Container.preferredSize(Container.
java:1178)
	at java.awt.Container.getPreferredSize(Container.
java:1162)
	at javax.swing.JComponent.
getPreferredSize(JComponent.java:1277)
	at javax.swing.ScrollPaneLayout.
layoutContainer(ScrollPaneLayout.java:769)
	at java.awt.Container.layout(Container.java:1020)
	at java.awt.Container.doLayout(Container.java:
1010)
	at java.awt.Container.validateTree(Container.
java:1092)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validateTree(Container.
java:1099)
	at java.awt.Container.validate(Container.java:
1067)
	at java.awt.Window.pack(Window.java:444)
	at org.netbeans.core.windows.services.
NbPresenter.initialize(NbPresenter.java:188)
	at org.netbeans.core.windows.services.
NbPresenter.<init>(NbPresenter.java:129)
	at org.netbeans.core.windows.services.NbDialog.
<init>(NbDialog.java:37)
	at org.netbeans.core.windows.services.
DialogDisplayerImpl$1.run(DialogDisplayerImpl.
java:57)
	at org.openide.util.Mutex$1.run(Mutex.java:938)
[catch] at java.awt.event.InvocationEvent.
dispatch(InvocationEvent.java:171)
	at java.awt.EventQueue.dispatchEvent(EventQueue.
java:454)
	at java.awt.EventDispatchThread.
pumpOneEventForHierarchy(EventDispatchThread.java:
201)
	at java.awt.EventDispatchThread.
pumpEventsForHierarchy(EventDispatchThread.java:
151)
	at java.awt.EventDispatchThread.
pumpEvents(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.
pumpEvents(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.
run(EventDispatchThread.java:100)
Comment 1 iamacat 2004-04-02 01:06:18 UTC
Created attachment 14250 [details]
My ide.log with exceptions
Comment 2 Milan Kubec 2004-04-05 09:37:20 UTC
Reassigning for evaluation, I cannot reproduce though.
Comment 3 _ tboudreau 2004-07-28 22:09:39 UTC
Not a problem on later versions of JDK 1.4.2 (bug reported on b28).
Comment 4 Marian Mirilovic 2005-07-12 10:14:38 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo