Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 39022 - Auto Update broken for restarting IDE
Auto Update broken for restarting IDE
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION
Depends on:
Blocks: 32053
  Show dependency treegraph
 
Reported: 2004-01-20 18:48 UTC by Jesse Glick
Modified: 2004-02-26 16:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-01-20 18:48:07 UTC
It seems that the AU client is currently broken
for updating existing modules. Try running a dev
build and downloading treefs from beta AU -
installs fine in user dir w/o restart. Now run AU
again on alpha AU and get the newer treefs (1.22
-> 1.26) and agree to restart. It is not
installed; treefs.nbm 1.26 stays in
$userdir/update/download/; every time you exit the
IDE it restarts.

Seems to be caused by a mistake in runide.sh (did
not check runide.exe) 1.51, not corrected in 1.52.

do_run_updater() {
    eval "\"$jdkhome/bin/java\"" -classpath
"\"${updatercp}\"" $jargs $updater_class
}

does not pass in the userdir any more, since
$jargs no longer includes
"-J-Dnetbeans.user=$userdir". Probably need to add
that explicitly.
Comment 1 Jaroslav Tulach 2004-01-23 12:54:54 UTC
Unix version fixed. Windows did not have this problem.

/cvs/core/release/bin/runide.sh,v  <--  runide.sh
new revision: 1.53; previous revision: 1.52
Comment 2 Jaroslav Tulach 2004-01-23 12:56:20 UTC
x
Comment 3 Lukas Hasik 2004-02-26 16:47:09 UTC
x


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo