Bug 38193 - Debugger Window not completely usable from keyboard
Debugger Window not completely usable from keyboard
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
3.x
Sun All
: P2 (vote)
: 3.x
Assigned To: issues@debugger
issues@debugger
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-17 19:16 UTC by _ gordonp
Modified: 2005-07-11 16:02 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gordonp 2003-12-17 19:16:29 UTC
If I've got focus in the editor and want to change
an already set breakpoint via the keyboard, it
takes between 20 and 25 keystrokes to shift focus
to the Debugger Window and then Ctrl-Tab down to
the breakpoints view.

So while we meet the 508 requirement that there is
keyboard access, in reality its soo time consuming
that debugging isn't really accessible.
Comment 1 Maros Sandor 2003-12-18 11:07:14 UTC
I assume you report the issue against 3.5. In 3.6 (trunk) I can 
switch to Breakpoints with Ctrl-Shift-7, press Tab and get to my 
breakpoint with arrows. If you have only 1 breakpoint, you can get 
there with 3 keystrokes.
Comment 2 _ gordonp 2003-12-18 19:42:53 UTC
Yes, I was filing against 3.5*. Glad to hear its already fixed!
Comment 3 Milan Kubec 2004-02-23 16:17:45 UTC
Please, could you verify if it's fixed.
Comment 4 _ gordonp 2004-02-23 17:32:05 UTC
I just tried to verify this with the beta 3.6 and could not. If
I type Ctrl+Alt+5 the Breakpoints tab gets highlighted but the
selection inside the window does not become active. Pressing the
tab key changes the selection in my Explorer window from blue to
grey. The arrow keys move the selection up/down in the explorer.

Things have changed since Maros fixed the bug (I'm assuming). His
message in this IZ mentions Ctrl+Shift+7 yet that doesn't appear
to have anything to do with the Breakpoints window now. The kb
shortcuts dialog does say the Ctrl+Alt+5 goes to the bp view,
and it does. But I'm not getting focus inside the view once
this happens.

So I'm reopening the issue, but hopefully its just user error
and Maros can tell me what I need to do to get it to work right.
Comment 5 Maros Sandor 2004-02-24 10:17:45 UTC
Shortcuts for debugger views changed after I wrote my comments hence 
the confusion. The right shortcuts are Alt-Shift-number now. However, 
in current builds the focus really does not switch correctly to 
debugger views. Pressing Alt-Shift-5 opens the Breakpoints view and 
the view is decorated by a blue shade BUT the keyboard focus is still 
in editor and pressing any key modifies the source file. So 
currently, debugger views and not accessible at all. I am assigning 
this to openide for evaluation.
Comment 6 Marian Mirilovic 2004-02-24 12:11:05 UTC
reproducible on [nb_dev](200402221900), [jdk1.4.2_03]

It seems like component is activated but focus is still in the
previously focused window ....
Comment 7 _ tboudreau 2004-02-24 12:27:16 UTC
Probably an issue for the debugger - I think the new winsys makes no assumptions about 
showing a window = request focus on a window.
Comment 8 David Simonek 2004-02-24 14:49:35 UTC
I agree - debugger guys, perhaps there is missing call
tc.requestActive(), which will give focus to calling component.
Comment 9 Maros Sandor 2004-02-24 15:21:28 UTC
The component (Breakpoints view) IS active, its method 
componentActivated() gets called as soon as it is highlited as being 
active. Even if I call requestActive() or 
myTreeTableInThatView.requestFocusInWindow() in that method it has no 
effect. It is highlited but still missing focus. I also cannot call 
JComponent.requestFocusInWindow() because it is overriden. Maybe I am 
missing something ... the focus? ;-)
Comment 10 Marian Mirilovic 2004-02-24 16:37:14 UTC
Maros, 
please reassigne it back to appropriate owner, thanks ;)
Comment 11 David Simonek 2004-02-24 16:38:42 UTC
I don't believe it's in winsys - please evaluate:
1) Is your action that is triggered by the shortcut calling
requestActive or not?
2) Isn't your component set to don't receive focus?
All other windows work fine, so there should be something specfic
about your windows - please find that out. I'm willing to help but I
need you to help me too.
Comment 12 Maros Sandor 2004-02-24 17:46:55 UTC
Thanks for help, I think I found it. I have overriden the 
requestFocusInWindow() of the TreeTableView to focus the right 
component (the treeTable). Imho it should be already overriden in 
TreeTableView.

/cvs/debuggercore/src/org/netbeans/modules/debugger/support/nodes/Tree
TableExplorerViewSupport.java,v  <--  
TreeTableExplorerViewSupport.java
new revision: 1.26; previous revision: 1.25
Comment 13 Milan Kubec 2004-02-25 10:04:31 UTC
Verified on linux. I'll verify WinXP too. Gordon, please verfiy on
Solaris.
Comment 14 Max Sauer 2005-07-11 16:02:18 UTC
Accessing debugger views is very easy in current builds. Just few keystrokes.
Therefore closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo