Bug 37962 - PMD rules module uses derecated APIs
PMD rules module uses derecated APIs
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: PMD
3.x
PC All
: P4 (vote)
: TBD
Assigned To: _ rkubacki
issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-10 10:48 UTC by _ rkubacki
Modified: 2006-10-27 08:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2003-12-10 10:48:47 UTC
[org.netbeans.core.modules #7] Warning - had to
upgrade dependencies for module
org.netbeans.modules.pmd.ext: added = [module
org.openide.src > 1.0, module org.openide.debugger
> 1.0, token
org.openide.compiler.CompilationEngine, module
org.openide.compiler > 1.0, token
org.openide.TopManager, module
org.openide.execution > 1.0, token
org.openide.windows.IOProvider, token
org.netbeans.api.javahelp.Help, module
org.openide.deprecated > 1.0, token
org.openide.execution.ExecutionEngine, module
org.openide.io > 1.0] removed = []; details: [API
separation phase I (#19443):
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.5i-sep-I,
API separation phase II (#19443):
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.5i-sep-II,
Debugger API separation (#29914):
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.5i-sep-III,
JavaHelp was moved into a module:
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.4-require-javahelp]
[org.netbeans.core.modules #7] Warning - had to
add recursive class loader dependencies for module
org.netbeans.modules.pmd.ext on
[org.netbeans.api.java]; see
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.5i-indirect-dep-cp
[org.netbeans.core.modules #7] Warning: the module
org.netbeans.modules.pmd.ext uses
org.openide.deprecated which is deprecated:
Clients of obsoleted Open APIs are encouraged to
remove this dependency. See
http://www.netbeans.org/download/dev/javadoc/OpenAPIs/org/openide/doc-files/upgrade.html#3.5i-sep-I
Installing new module: PMD Rules for NetBeans
Turning on modules:
	pmd [0.90]
	org.netbeans.modules.pmd.ext/1 [1.4]
Comment 1 _ rkubacki 2004-01-19 13:53:25 UTC
/cvs/contrib/pmd-nb-ext/manifest.mf,v  <--  manifest.mf
new revision: 1.6; previous revision: 1.5


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo