Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37721 - ComboBox in a properties view does not work
ComboBox in a properties view does not work
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-03 21:34 UTC by Tim Lebedkov
Modified: 2008-12-22 17:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2003-12-03 21:34:40 UTC
Hi,

my property editor for a priority
(http://tasklist.netbeans.org/source/browse/tasklist/core/src/org/netbeans/modules/tasklist/core/editors/PriorityPropertyEditor.java?rev=1.5&content-type=text/x-cvsweb-markup)
does not work in
a property sheet (I'm not able to change the
value. The same editor works in a TreeTableView

--Tim
Comment 1 _ tboudreau 2003-12-03 22:45:38 UTC
I believe this is a duplicate of another issue, and its already fixed
on the property panel rewrite branch - the problem was that the
editable combo box renderer was setting the text in its editor but not
laying itself out correctly.

Given that tasklist is a heavy user of TreeTableView, I'd really
appreciate it if you could test out what's on the branch - it's
planned to be merged a week from today, so I want to get it as tested
as possible (also let me know if this problem is indeed fixed on the
branch - I'm 99% sure it will be).  Keyboard navigability and a bunch
of other stuff is fixed in TTV on the branch.

Here's what to do:

cd $NB_SRC/openide/src/org/openide/explorer/propertysheet
cvs update -r proppanel_rewrite
cd ../view
cvs update -r proppanel_rewrite2

(there are some unit tests and one class in Jelly branched as well,
but I presume you don't need those).  Yes, the branch names are
different for the two directories, that's not a mistake.
Comment 2 Tim Lebedkov 2003-12-04 21:19:50 UTC
Yes! It works! One-click editing and keyboard navigation are great.
Thank you

But I also found one small issue:
With these 2 columns:
priority: combobox as the editor
done: checkbox as the editor
If I use space to toggle the "done" property the combobox get opened

--Tim Lebedkov
Comment 3 _ tboudreau 2003-12-04 21:40:42 UTC
Hmmm...which cell has focus when you press space - and what is the
order of the fields?  

TreeTable.editCellAt is overridden to check if the property is
boolean, and if it is, toggle the value without ever instantiating an
editor - that should happen on keyPressed.  I'm wondering if there's a
second keyPressed finding its way in there somehow, or something else
going on.


BTW, I did some digging around on the net for various tree table
implementations out there.  It's amazing the number of them.  One
interesting one belongs to a defunct mozilla project called Grendel,
but it has very little to do with Swing.  I also will take a look at
yours.  At the moment I'm just hoping that the band-aids in this patch
will breathe enough life into the existing tree table view that it can
survive usably until I get a few million other things off my plate.
Comment 4 _ tboudreau 2003-12-09 09:37:02 UTC
Property panel rewrite branch merged.
Comment 5 Tim Lebedkov 2004-09-28 20:01:50 UTC
ok


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo