Bug 37272 - Need translations of o.n.c.windows/2
Need translations of o.n.c.windows/2
Status: RESOLVED WONTFIX
Product: nblocalization
Classification: Unclassified
Component: Code
4.x
All All
: P2 (vote)
: TBD
Assigned To: vbrabant
issues@nblocalization
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 11:48 UTC by Jesse Glick
Modified: 2008-10-11 14:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-11-17 11:48:56 UTC
www/www/updates/alpha/dev_1.6_.xml still includes
only translations of org.netbeans.core.windows/1,
which no longer exists in the trunk.

Cf. issue #37271.
Comment 1 _ mihmax 2003-11-17 13:10:19 UTC
Not sure I Understand the problem, Jesse

Maybe it's just that localized AU are not maintained at all, not the
missing translation?
Comment 2 Jesse Glick 2003-11-17 13:28:08 UTC
I don't know what the status of particular translations in
translatedfiles is; I am just pointing out that for whatever reason,
dev alpha AU contains a core-windows_fr.nbm etc. which is marked with
major release version 1, whereas in the dev trunk (as of the winsys2
merge) it should have version 2. So something is wrong. Probably the
fix can wait until the next release.

May be duplicate of issue #37273, in case the build process actually
creates the correct /2 NBM but this is just not getting published. TBD.

Note that the winsys2 merge rearranged the whole o.n.c.windows.**
package hierarchy quite a bit and it is likely that translated bundles
need to be rearranged to match.
Comment 3 _ mihmax 2003-11-18 08:28:43 UTC
Since this issue is about french files,
then it belongs to Vincent Brabant.

Vincent, please take a look
Comment 4 Jesse Glick 2003-11-18 08:39:35 UTC
Actually I think it applies to the other languages too, but I noticed
it with _fr.
Comment 5 vbrabant 2003-11-18 10:57:03 UTC
Is that issue a blocking issue ?
Because, this month I would like to be concentrated by writing somes
tests for the tasklist module.

And I have no idea what's exactly wrong in fact.
I understand that somewhere (a xml file, but which one exactly. Until
now, Maxym managed that for me. So) our module is doing a reference to
an old version of the core module.

But it's normal because the french translation is translation of
core/windows/1 and not yet core/windows/2.
For me, the module would appear only in Alpha Update Center of
NetBeans version having core/windows/1 but certainly not core/windows/2.

Question is: Does I have to modify the xml file at my side to change
the dependance and put core/windows/2 in place of core/windows/1, or 
does I have to forward the problem to the Update Center Module to fixe
the fact that they have to propose only modules that are depending of
version only if the good version is installed on the pc ?
Comment 6 Jesse Glick 2003-11-18 14:38:45 UTC
I don't think it's blocking anything, I'm just reporting it.

As to where the problem lies, or how translatedfiles is built, I have
no idea. All I know is that the file

www/www/updates/alpha/dev_1.6_.xml

is served to dev builds asking for alpha-level modules. These builds
now have a /2 core-windows.jar, yet are being offered /1 translations
which cannot possibly work. Maybe you just want to ignore that until
the next release.
Comment 7 _ mriem 2004-11-09 15:36:38 UTC
Vincent any updates on this issue?
Comment 8 Jeremie Bertolino 2008-10-11 14:45:30 UTC
5 years old issue - no updates for 4 years.
Hence closing. 
Please re-open if still valid.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo