Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37169 - Monitor displays empty records
Monitor displays empty records
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: HTTP Monitor
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Ana.von Klopp
issues@javaee
:
Depends on:
Blocks: 35833
  Show dependency treegraph
 
Reported: 2003-11-12 14:41 UTC by L Martinek
Modified: 2004-01-12 17:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
NullPointerException (2.27 KB, text/plain)
2003-11-12 14:41 UTC, L Martinek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description L Martinek 2003-11-12 14:41:07 UTC
Found in build 200311111900, jdk 1.4.2_02.

I executed one JSP three times. HTTP Monitor had
three nodes under Current Records, but when I
selected one of them, no data was displayed. If I
tried to click on all tabs of HTTP monitor, NPE
was thrown.
Comment 1 L Martinek 2003-11-12 14:41:56 UTC
Created attachment 12122 [details]
NullPointerException
Comment 2 Ana.von Klopp 2003-11-12 17:26:15 UTC
Hi Libor,

I just downloaded that build from www.netbeans.org but it appears to 
be very reduced in terms of functionality? I tried to reproduce it 
with my previous installs but can't. 
Comment 3 Ana.von Klopp 2003-11-14 01:25:04 UTC
This problem was due to the integration by Jesse Glick which changed 
the node behaviour (see issue 36479 for more info). I backed out those 
changes. There were some additional problems in addition to this one 
(e.g. if you save a transaction, all current transactions are removed; 
the component could not start if there were any saved transactions, 
etc, etc). 

When testing that the backout fixed the problem, I discovered one 
remaining issue from the schema2beans update (36882) which prevented 
some tabs from displaying data on some conditions. I modified 
MonitorFilter.java to have that fix. 
Comment 4 Ana.von Klopp 2003-11-14 01:37:21 UTC
Forgot to mark as fixed
Comment 5 Jesse Glick 2003-11-14 11:19:38 UTC
Adding reminder that the reverted changes will probably need to be
reapplied (in some corrected form of course) for the changes covered
by issue #35833, judging by architecture bugs I discovered w.r.t.
threading in this module.

Issue #36479 is probably not related to this at all.
Comment 6 L Martinek 2004-01-12 17:14:31 UTC
verified
Comment 7 L Martinek 2004-01-12 17:30:55 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo