Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37156 - Too many open files exception
Too many open files exception
Status: RESOLVED DUPLICATE of bug 33856
Product: utilities
Classification: Unclassified
Component: Search
3.x
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: issues@utilities
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 09:10 UTC by Rafal Smyka
Modified: 2003-11-12 10:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
zipped IDE log (37.79 KB, application/octet-stream)
2003-11-12 09:15 UTC, Rafal Smyka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafal Smyka 2003-11-12 09:10:05 UTC
While searching for a substring in files of type
JSP || Java Source I've got a 'too many open
files' exception (see the stack trace below).
After that my windows and workspaces were gone.

The message window suggested to append the IDE

Regards,
Rafal

java.io.IOException: Too many open files
	at java.io.FileInputStream.open(Native Method)
	at
java.io.FileInputStream.<init>(FileInputStream.java:106)
	at
org.netbeans.modules.cvsclient.NbJavaCvsFileSystem$NbInfoImpl.inputStream(NbJavaCvsFileSystem.java:516)
	at
org.openide.filesystems.DefaultAttributes.load(DefaultAttributes.java:536)
	at
org.openide.filesystems.DefaultAttributes.loadTable(DefaultAttributes.java:517)
	at
org.openide.filesystems.DefaultAttributes.readAttribute(DefaultAttributes.java:279)
	at
org.netbeans.modules.cvsclient.NbJavaCvsFileSystem$JavaCvsAttributes.readAttribute(NbJavaCvsFileSystem.java:1718)
	at
org.openide.filesystems.AbstractFileObject.getAttribute(AbstractFileObject.java:270)
	at
org.openide.filesystems.AbstractFileObject.getAttribute(AbstractFileObject.java:265)
	at
org.openide.loaders.DataLoaderPool.getPreferredLoader(DataLoaderPool.java:422)
	at
org.openide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:346)
	at
org.openide.loaders.FolderList.createBoth(FolderList.java:653)
	at
org.openide.loaders.FolderList.getObjects(FolderList.java:464)
	at
org.openide.loaders.FolderList.access$200(FolderList.java:50)
	at
org.openide.loaders.FolderList$ListTask.run(FolderList.java:829)
	at org.openide.util.Task.run(Task.java:136)
	at
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:328)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:670)
Comment 1 Rafal Smyka 2003-11-12 09:15:55 UTC
Created attachment 12114 [details]
zipped IDE log
Comment 2 Marian Petras 2003-11-12 10:01:14 UTC
It is already fixed in the development version. See bug #33856 for
more information.

*** This issue has been marked as a duplicate of 33856 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo