Bug 37032 - [I18N] Difficulty typing in Japanese in Editor
[I18N] Difficulty typing in Japanese in Editor
Status: RESOLVED DUPLICATE of bug 14549
Product: editor
Classification: Unclassified
Component: -- Other --
3.x
PC Windows ME/2000
: P2 with 1 vote (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: I18N
Depends on:
Blocks: 45719
  Show dependency treegraph
 
Reported: 2003-11-04 19:38 UTC by cahrens
Modified: 2007-11-05 13:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cahrens 2003-11-04 19:38:32 UTC
With a plain JEditorPane (no NetBeans classes), 
an underline appears below characters before they 
have been accepted in Japanese mode.  

However, in our NetBeans-based Editor this does 
not happen.  This makes it very difficult to type 
Japanese text in the editor.
Comment 1 Miloslav Metelka 2004-01-23 16:04:08 UTC
You are right, we do not highlight the background of the typed text in
input method. We need to start to support element breaking in the
editor in order to allow this.
Comment 2 Roman Strobl 2005-01-10 13:16:41 UTC
Changed target milestone to TBD.
Comment 3 Miloslav Metelka 2005-03-31 13:03:52 UTC
Setting TM to future.
Comment 4 Ken Frank 2006-06-02 05:55:48 UTC
nb day 06 survey mentioned this issue specifically;
am raising it to p2; can it be considered for nb6.0 ?

ken.frank@sun.com
Comment 5 Miloslav Metelka 2006-06-02 11:55:06 UTC
We will resolve this for 6.0. Either by the new Editor API that we're preparing
or by tweaking the old APIs.
I've got an idea that instead of implementing breaking of the elements we could
store the composed text information as a document property an have a drawing
layer that would render the highlight according to the property. That could
simplify the implementation with the same result. I'll try to check this.
Comment 6 Vitezslav Stejskal 2006-10-13 01:28:58 UTC
It looks like the same problem as the issue #14549.

*** This issue has been marked as a duplicate of 14549 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo