Bug 36840 - a11y: focus has been lost in Source Editor view.
a11y: focus has been lost in Source Editor view.
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
-S1S-
All All
: P3 (vote)
: 4.x
Assigned To: Jan Stola
issues@utilities
: A11Y, FOCUS
Depends on: 40507
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 09:54 UTC by tanya
Modified: 2004-08-13 12:11 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tanya 2003-10-27 09:54:13 UTC
Product Version:  Sun ONE Studio 5  Standard
Edition (Build 030904)
IDE Versioning:   IDE/1 spec=3.42.2 impl=030904
Operating System: SunOs version 5.8 running on sparc
Java:             1.4.1_05


    To reproduce the bug:
    
1. Having focus in the Explorer[Filesystem],
   create Properties File through
File/New/Other/Properties File.
   
   Source editor view appears, but focus is on the
node created.
   
ISSUE 1:  Focus should be in Source Editor view.
Ctrl-3 highlihgts
          Source Editor[<Properties File> node *]
view, but focus
          remains in Filesystems view.
   
ISSUE 2: There are no properties in the table yet,
but 'Remove Property'
         button is enabled.
                  
2. Fource focus into Source Editor view using
mouse and create New Property.
3. Press Space in Key or Value table cell to start
editing.

ISSUE 3: You can`t move focus to the next
component using Ctrl-Tab.
Comment 1 Marian Petras 2004-02-26 08:01:19 UTC
I am able to reproduce all the three mentioned issues on a PC+Linux
platform with a NetBeans 3.6 beta. They will not be fixed in NetBeans 3.6.

Issue #1 is caused by bug #40507 ("Activating a TopComponent does not
move focus to its focus cycle").
Comment 2 Jan Stola 2004-07-21 10:45:09 UTC
issue 1: fixed - the focus is moved into the editor by now.

issue 2: fixed - Remove Property button is disabled when no
  property is selected (for example when there is no property).

issue 3: this seems to be a misunderstanding. It works correctly.
  The only "problem" is that (on some look and feels?) Ctrl+Tab
  moves focus on the scrollbar of the textarea. After that just
  simple Tab must be used to move focus to the next component.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo