Bug 36195 - a11y: Debugger Window does not has focus after pushing CTRL-5
a11y: Debugger Window does not has focus after pushing CTRL-5
Status: VERIFIED DUPLICATE of bug 38130
Product: platform
Classification: Unclassified
Component: Window System
3.x
Sun Solaris
: P3 (vote)
: TBD
Assigned To: mslama
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-19 07:59 UTC by ccv
Modified: 2008-12-23 11:53 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ccv 2003-09-19 07:59:57 UTC
1. Select example java program in explorer window
and open it in the Source Editor.
   class example {
     public static void main(String[] args) {
      int i;
      i=1;
     }
   }
2. Set focus is in the Source editor
3. Push F7(Step into), focus is on the first line
"i=1"
4. Push Alt-D/S/R (Run in Debugger menu item)
5. Push the Finish and Start button in the Start
New Session dialog
6. Focus is in the Output Window/Process Output.
7. Push CTRL-5 (swith to the Debugger window)
ISSUE: 
    Debugger window appears and is selected, but
focus remains in the Output window. 
    Symbol "5" is typed in the Output window.
    Push the Tab key several times. Focus moves in
the Output window.
    Impossible to reach any views in the Debugger
Window.
Comment 1 ccv 2003-09-19 08:03:39 UTC
Netbeans 3.5.1 IDE/1 spe=3.42.2
jdk 1.4.1_03
Comment 2 pzajac 2003-09-19 10:09:56 UTC
reassigned to core/windows
Comment 3 mslama 2003-10-10 14:45:27 UTC
Reproducible in current dev build 200310100100. It could be problem
with View Debugger Window action.
Comment 4 mslama 2003-10-10 14:46:22 UTC
I have Linux, RH 8, KDE 3.0.3, JDK 1.4.2_01.
Comment 5 Marian Mirilovic 2003-11-26 12:56:15 UTC
Because Window System v1 will not be supported from now by our team, all old
winsys issues (now "core/window system v1" issues) are going to be closed as
WONTFIX. 

Changes in API which emerged both from UI spec 
and problems with adjusting to the older API are described in the document
http://core.netbeans.org/windowsystem/changes.html.
 It shows also recommends how the client code should be adjusted to the new
window system.

If you think this issue apply also to the new winsys then change the
subcomponent (to "core/window system") and REOPEN it.
Comment 6 ccv 2003-11-26 13:15:40 UTC
Yes, I think this issue apply also to the new winsys.
Comment 7 _ tboudreau 2004-02-20 14:41:10 UTC
Closing as duplicate of issue 38130.  Focus *is* in the debugger window, but a known bug 
in TreeTableView prevents indication of it from being painted.  This will be fixed in the 
TreeTableView rewrite for promotion D.

*** This issue has been marked as a duplicate of 38130 ***
Comment 8 Marian Mirilovic 2004-03-01 08:26:45 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo