Bug 35922 - a11y: Focus does not move to the Explorer window
a11y: Focus does not move to the Explorer window
Status: VERIFIED DUPLICATE of bug 24877
Product: platform
Classification: Unclassified
Component: Window System
3.x
Sun All
: P3 (vote)
: TBD
Assigned To: mslama
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 09:12 UTC by ccv
Modified: 2008-12-23 11:44 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ccv 2003-09-05 09:12:17 UTC
Product Version: Sun ONE Studio, Native Edition
(Build 18)
Java:	         1.4.1_03

To reproduce:

1. Mount and select any directory in the Explorer
window.
2. Push Shift-F10 and select Properties with
keyboard.
3. Focus is in the single Properties window. 
4. I want to return in the Explorer and push
ALT-V; 
==> ISSUE1: Properties window overlaps the View
popup menu.
5. Push the ESC key, popup is closed.
   Push CTRL-2 (Explorer window)

==> ISSUE2: Explorer window is selected but focus
remains in the Properties window. Needs to close
Properties for continue working.
Comment 1 Marian Mirilovic 2003-09-05 09:52:15 UTC
MDI or SDI ?
Comment 2 ccv 2003-09-05 09:54:26 UTC
MDI mode
Comment 3 ccv 2003-09-05 10:11:34 UTC
With more details: in SDI mode, the second issue is observed only,
push CTRL-V and focus remains in the Property windows.
Comment 4 mslama 2003-09-15 13:04:13 UTC
Problem with transfrerring focus is already fixed in main trunk. See
issue #33940 and issue #24877.

*** This issue has been marked as a duplicate of 24877 ***
Comment 5 mslama 2003-09-15 13:10:42 UTC
Regarding menu and Properties window overlap: It is z-order.
Properties window is above of main window and menu is lightweight
component with main window as parent so it is behind Properties
window. I think it is correct. If you disagree you can file separate
issue and ask UI how it should behave. It is simply result of mixing
MDI with separate native windows. But it will be the same for pure SDI.
Comment 6 Marian Mirilovic 2004-03-01 08:22:52 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo