Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 35659 - Progress indicator as part of status line
Progress indicator as part of status line
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
All All
: P3 (vote)
: 5.x
Assigned To: Milos Kleint
issues@platform
: API
Depends on:
Blocks: 35605 50356
  Show dependency treegraph
 
Reported: 2003-08-21 11:12 UTC by mvinar
Modified: 2008-12-22 20:32 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mvinar 2003-08-21 11:12:01 UTC
User problem:
-----------------------------------
Tasks which take time are not consistently
presented and many of them do not show progress
towards completion.

User need:
-----------------------------------
--

Product requirement:
-----------------------------------
Progress indicator as part of status line (show
running tasks and their progress, allow to kill them)
Comment 1 _ tboudreau 2003-08-24 01:19:28 UTC
Setting to block issue 35605, editor statusbar merge - these
present similar issues (multiple status providers), which 
needs to be solved for both issues.

Difficulty: 4 (requires new API)
Hack-factor: 0 (if done right)

This shouldn't really be all that difficult, it's mainly
the API introduction issue that pushes the difficulty factor
up.
Comment 2 Jan Chalupa 2004-11-01 16:56:27 UTC
Re-assigning Tim's issues to Dafe.
Comment 3 David Simonek 2005-05-05 17:17:34 UTC
I think this is duplicate of what Milos is just working on, so passing to him to
resolve.
Comment 4 Milos Kleint 2005-05-10 08:28:38 UTC
done, integrated into trunk. new module org.netbeans.api.progress


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo