Bug 34402 - Unable to execute query,null
Unable to execute query,null
Status: VERIFIED DUPLICATE of bug 42956
Product: db
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P3 with 2 votes (vote)
: 5.x
Assigned To: Andrei Badea
issues@db
: RANDOM
: 34326 34968 35365 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-16 09:26 UTC by walterluetgenau
Modified: 2006-03-29 09:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description walterluetgenau 2003-06-16 09:26:17 UTC
I can connect to a Oracle9i database all right. The 
explorer has access to the metadata (the table and column 
structure is displayed). But whenever I try to execute a 
query, a message box tells me "unable to execute 
query,null". 

If I try to execute an erronous query, e.g. on a not 
existing table, I get the appropriate ORA error message, 
so the qery gets executed at least in this case.

The database explorer worked fine in previous releases 
(where the database explorer had to be downloaded as an 
additional module) with the same oracle jars. The 
databases have been imported by "import settings" during 
the installation, but I tried as well to create a new 
database node. With this node the query did not work 
either.
Comment 1 Radko Najman 2003-07-03 09:16:30 UTC
*** Issue 34326 has been marked as a duplicate of this issue. ***
Comment 2 Radko Najman 2003-07-03 09:21:34 UTC
Cannot reproduce. Is any exception thrown?
Comment 3 Martin Schovanek 2003-07-22 16:09:06 UTC
[s1s5, jdk1.4.2, Oracle9]

I have seen this too. Command Editor throwed message "unable to execute 
query,null" although command was sucessfuly executed and the command
didn't appear in combo with recent commands. No other exception was
thrown.
Comment 4 jeppy 2003-07-28 19:20:38 UTC
[win2k, jdk1.3.1, SQLServer 8]
I have seen the same issue connecting through SQL Server through the
ODBC bridge.  This is the only issue that has prevented me from
uninstalling NB 3.4.1.
Comment 5 Radko Najman 2003-07-30 11:16:08 UTC
*** Issue 34968 has been marked as a duplicate of this issue. ***
Comment 6 Radko Najman 2003-08-06 16:39:37 UTC
Still cannot reproduce neither with 3.5 or dev build. Could you try to
reproduce it with dev build, please? View data/Execute command dialog
was a bit reimplemented after 3.5 release so maybe this build will
work for you.

(Tested with Oracle9, MSSQL, Sybase ASA, PostgreSQL 7.3.3 and
Pointbase 4.2; JDK 1.4.2)
Comment 7 Radko Najman 2003-08-12 08:04:08 UTC
*** Issue 35365 has been marked as a duplicate of this issue. ***
Comment 8 Radko Najman 2003-09-09 13:43:05 UTC
I got no feedback that it was reproducible with NetBeans dev build so
closing as WORKSFORME.
If you are able to reproduce it with NetBeans dev build, please feel
free to reopen this issue.
Comment 9 dmladek 2004-08-23 15:30:11 UTC
Well, with NB DEV (4.0 after Beta1 candidate) #20040822-1800,
With oracle DB 9.2 I'm getting SOMETIMES following message:

"Unable to execute query, Porušení protokolu."

But it's IMHO caused by bug in Ora JDBC driver...
It has problem running 2 SQL commands parralery...
This's been entered in IZ.. I don't know the number...

Thus this bug is probably the dup of mentioned issue (which I hope
I'll find)
Comment 10 dmladek 2004-08-23 15:39:02 UTC
I've found it! It is the issue #42956
But problem is that that bug is reproductable only with Ora JDBC
drivers. EG It wasn't possible to reproduce it on DB2,
and this bug happens also on DB2 like duplicates shows
Comment 11 dmladek 2004-08-23 15:45:09 UTC
downgrading....to P3 and waiting for Radko's response what he think.
Comment 12 Andrei Badea 2005-12-01 15:20:42 UTC
Likely duplicate of issue 42956.

*** This issue has been marked as a duplicate of 42956 ***
Comment 13 Lukasz Grela 2006-03-29 09:41:46 UTC
v.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo