Bug 33778 - "Add Method Breakpoint" on the method node in Classes View not working
"Add Method Breakpoint" on the method node in Classes View not working
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
-S1S-
Sun SunOS
: P3 (vote)
: 3.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-20 14:56 UTC by Jan Lahoda
Modified: 2003-12-11 14:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lahoda 2003-05-20 14:56:54 UTC
Nevada, RC4 (030516), JDK1.4.1_02, MDI.
Steps to reproduce:
1. Start debugging of the examples.advanced.MemoryView
2. Wait a minute, until the debugger is started
3. Go into Classes View, and select node:
"examples/advanced/MemoryView/Methods/updateStatus".
4. Invoke context menu (right-click)
5. Select Add Method Breakpoint
6. The breakpoint is not added at all.

Analysis:
The method
org.netbeans.modules.debugger.support.DebuggerSupport.createBreakpoint(ConstructorElement)
(in module debuggercore) is called.
The body of this method has been commented out,
and the breakpoint therefore cannot be set.
Comment 1 Jan Jancura 2003-05-27 15:00:08 UTC
looks like the real problem!
Comment 2 Maros Sandor 2003-07-15 12:23:23 UTC
Checking in BreakpointSupport.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/support
/BreakpointSupport.java,v  <--  BreakpointSupport.java
new revision: 1.38; previous revision: 1.37

Checking in DebuggerSupport.java;
/cvs/debuggercore/src/org/netbeans/modules/debugger/support
/DebuggerSupport.java,v  <--  DebuggerSupport.java
new revision: 1.43; previous revision: 1.42
Comment 3 Jan Lahoda 2003-10-31 15:12:57 UTC
Verified in NB200310281900.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo