Bug 33469 - Get rid of 500ms wait in DataSystems
Get rid of 500ms wait in DataSystems
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Data Systems
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Jaroslav Tulach
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-07 15:22 UTC by Jaroslav Tulach
Modified: 2008-12-22 21:22 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2003-05-07 15:22:23 UTC
I think I know how to get rid of 500ms problem in
data object constructor. I have reported that as
part of another issue, but I'd like it to not be
forgotten and that is why I am reporting it
separatelly. 

The basic problem of 500ms was proper
implementation of
OperationListener.postCreateNotify that was
supposed to be called after construction of each
object. As we know now, there is no way to find
out that a constructor of an object finished, and
that is why introduced the 500ms wait. But now I
think there is a better way. Notify only creation
of objects from DataObject.find - anyway this is
99% of objects so that will work almost perfect.
See the diff:

http://www.netbeans.org/issues/showattachment.cgi?attach_id=10198

Right now it disallows creation of DataObject
outside of DataObject.find, but this can be
changed to a warning - such objects will not be
notified to the OperationListener.
Comment 1 Jesse Glick 2003-05-07 15:28:03 UTC
Would be nice - does it seem to work well?
Comment 2 Jaroslav Tulach 2003-05-12 11:16:03 UTC
Seems to work (except for DataObject.copy which I fixed on my local
disk). I will ask QA to do full test on the build and then proceed
towards the integration.
Comment 3 Jaroslav Tulach 2003-05-12 20:30:42 UTC
Module openide has been branched to hold work being done on this
issue. The branch is named timing_33469 - use

cvs co -r timing_33469 openide

to get its current version.
Comment 4 Jaroslav Tulach 2003-05-16 13:10:30 UTC
Checking in loaders/build.xml;
/cvs/openide/loaders/build.xml,v  <--  build.xml
new revision: 1.6; previous revision: 1.5
done
Checking in loaders/manifest.mf;
/cvs/openide/loaders/manifest.mf,v  <--  manifest.mf
new revision: 1.3; previous revision: 1.2
done
Processing log script arguments...
Mailing the commit message to cvs@openide.netbeans.org (from
jtulach@netbeans.org)
Checking in loaders/src/org/openide/loaders/DataFolder.java;
/cvs/openide/loaders/src/org/openide/loaders/DataFolder.java,v  <-- 
DataFolder.java
new revision: 1.5; previous revision: 1.4
done
Checking in loaders/src/org/openide/loaders/DataLoader.java;
/cvs/openide/loaders/src/org/openide/loaders/DataLoader.java,v  <-- 
DataLoader.java
new revision: 1.3; previous revision: 1.2
done
Checking in loaders/src/org/openide/loaders/DataLoaderPool.java;
/cvs/openide/loaders/src/org/openide/loaders/DataLoaderPool.java,v 
<--  DataLoaderPool.java
new revision: 1.3; previous revision: 1.2
done
Checking in loaders/src/org/openide/loaders/DataObject.java;
/cvs/openide/loaders/src/org/openide/loaders/DataObject.java,v  <-- 
DataObject.java
new revision: 1.3; previous revision: 1.2
done
Checking in loaders/src/org/openide/loaders/DataObjectPool.java;
/cvs/openide/loaders/src/org/openide/loaders/DataObjectPool.java,v 
<--  DataObjectPool.java
new revision: 1.3; previous revision: 1.2
done
Checking in loaders/src/org/openide/loaders/MultiDataObject.java;
/cvs/openide/loaders/src/org/openide/loaders/MultiDataObject.java,v 
<--  MultiDataObject.java
new revision: 1.4; previous revision: 1.3
done
Processing log script arguments...
Mailing the commit message to cvs@openide.netbeans.org (from
jtulach@netbeans.org)
Checking in test/unit/src/org/openide/loaders/BasicDataObjectTest.java;
/cvs/openide/test/unit/src/org/openide/loaders/BasicDataObjectTest.java,v
 <--  BasicDataObjectTest.java
new revision: 1.6; previous revision: 1.5
done
Checking in test/unit/src/org/openide/loaders/DataFolderTest.java;
/cvs/openide/test/unit/src/org/openide/loaders/DataFolderTest.java,v 
<--  DataFolderTest.java
new revision: 1.21; previous revision: 1.20
done
Checking in
test/unit/src/org/openide/loaders/DataObjectInvalidationTest.java;
/cvs/openide/test/unit/src/org/openide/loaders/DataObjectInvalidationTest.java,v
 <--  DataObjectInvalidationTest.java
new revision: 1.12; previous revision: 1.11
done
Checking in test/unit/src/org/openide/loaders/TemplateWizardTest.java;
/cvs/openide/test/unit/src/org/openide/loaders/TemplateWizardTest.java,v
 <--  TemplateWizardTest.java
new revision: 1.2; previous revision: 1.1
done
Comment 5 Jaroslav Tulach 2003-10-07 08:34:20 UTC
*** Issue 35897 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo