Bug 33145 - Form editor does not get focus in SDI mode
Form editor does not get focus in SDI mode
Status: RESOLVED WORKSFORME
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows 95/98
: P2 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-22 23:20 UTC by bht
Modified: 2004-04-01 14:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2003-04-22 23:20:32 UTC
IDE 3.5 Beta (Build 200304142350)
Java 1.4.1-b21

How to reproduce:

- Ensure that at least 1 form is already open in
the form editor
- Open the Explorer and select a node with a form
in it.
- Select "Design this Container" in the context
menu of a container of this form.

Expected behavior:
The form editor should gain focus.

Actual behavior:
Nothing happens, the explorer window still has focus.
Comment 1 Tomas Pavek 2003-04-30 18:32:57 UTC
Ok, the focus should be transferred.
Comment 2 bht 2004-04-01 08:56:51 UTC
This worked in previous versions of NetBeans.
IMHO such broken behavior in such a fundamental function should not
get a "future" milestone.
I am changing the priority only to get this issue to attract the
attention it deserves. I feel it is not my job to change milestones.
Comment 3 Tomas Pavek 2004-04-01 14:20:07 UTC
Ok, I've just checked it in NB 3.6 RC1 in SDI and it works for me -
the form designer window gets focused. It has likely been fixed with
all the changes done in the window system and form editor.

Since I don't remeber any particular fix I just mark this as
WORKSFORME in 3.6. Please verify.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo