Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 32755 - Editor focus lost.
Editor focus lost.
Status: RESOLVED DUPLICATE of bug 119617
Product: editor
Classification: Unclassified
Component: -- Other --
3.x
All Linux
: P4 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-09 10:45 UTC by willow
Modified: 2008-05-07 09:41 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description willow 2003-04-09 10:45:51 UTC
When typing into the editor if often find the
focus lost.

One situation where this ALWAYS happens on my
system is this:
1) Start Tomcat internal server.
2) Edit some JSP-file and save it.
3) If somebody on my network asks this JSP-file
through the Tomcat webserver, it starts compiling
the JSPfile (as it should), but my focus on the
editor is lost.

So my keystrokes go to dev/null. :-(

This may not be a problem for people who can type
blind (is this also an english experssion?) but I
cannot and look at my keyboard a lot while typing.

(I suspect this behaviour has noting to do with
Tomcat, but with starting a compile.)
Comment 1 mutable 2007-11-01 17:34:44 UTC
Hi. I can conform this bug. I lost focus in editor, text fields.

When I'm in editor and some dialog window appears I lost focus in editor.

Reproduce:
1) Go to the editor.
2) Type Ctrl-O to show "Open Type dialog" and then close it (by Esc even by Close window button).
   Now I cannot type to editor

When I open some dialog window and switch to another application (only by Alt-Tab) I lost focus in dialog text fields.

Reproduce:
1) Open services and click to add new database driver.
2) Switch to another application with Alt-Tab.
   When I return back to the netbeans I cannot type to dialog window text fields.

It happens very very often to me and it makes this otherwise great IDE useless for me.

I'm running Ubuntu 7.10.
Java version:
  java version "1.6.0_03"
  Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
  Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

It happens in NetBeans IDE 5.5.1 and Netbeans NetBeans IDE 6.0 Beta 1.

I'm not sure if it is NetBeans issue because similar thing happened to me in iReport, but there I'm not using keyboard
so often.
Comment 2 Vitezslav Stejskal 2007-11-02 10:14:47 UTC
I'm pretty sure that some of the problems lie in between your OS and JDK. The tomcat-start-jsp-compile issue however
sounds like something in Netbeans. Willow, could you please check that the focus in this case is not transferred to the
output window? Thanks
Comment 3 willow 2007-11-02 10:35:04 UTC
Hi guys,

I am sorry to say, but that report of mine was from april 2003.
Since then I stopped working with Java in favor of PHP, even though I made a lot more $ with Java, I just fell in love
with PHP.

And what is more, my old machine where I worked on (Redhat8) is no more alive. Total HD disaster, and being incredible
stupid, I had no recent backups. (Won't happen to me in the future.)
So I am not in the situation to check anything for you.
Sorry about that. :-/

Good luck fixing the issue!

Regards,
Erwin Moller
Comment 4 Vitezslav Stejskal 2007-11-02 11:03:51 UTC
Hi Erwin, thanks for your reply. We are sorry for catching up with you on this so late. Good luck with PHP. Should you
ever think about coming back to java, please make sure you check new Netbeans 6 out. It's a WAY better than the old 3.4.
Thanks, Vita
Comment 5 Jiri Prox 2008-04-11 00:46:26 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 6 Vitezslav Stejskal 2008-05-07 09:41:59 UTC
Although the problems described here may be unrelated, I'm marking this as a duplicate of issue #119617 - Cursor lost in
editor.

*** This issue has been marked as a duplicate of 119617 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo