Bug 32672 - Focus lost after pushing Next by keyboard in Import Settings Wizard
Focus lost after pushing Next by keyboard in Import Settings Wizard
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
Sun SunOS
: P3 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-07 11:22 UTC by Marian Mirilovic
Modified: 2008-12-22 16:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2003-04-07 11:22:39 UTC
[nb_3.5](200304062350), [jdk1.4.2](b19)

Steps to reproduce:
- run IDE
- push Enter
-> focus is lost forever, you must use mouse to
take it back
Comment 1 David Konecny 2003-04-07 11:57:55 UTC
This works fine in JDK 1.3.x and does not work on JDK 1.4.x. I think
the problem is in window system. I'm moving issue there. It is
possible that it can be also in wizard subsystem.

The temporary fix could be to focus something when panel is switched.
But this would have to be done in all panels. I would prefer to fix
the root cause rather then workarounding it in bunch of places.
Comment 2 mslama 2003-04-08 13:46:32 UTC
Need to check where is focus going. I think that there is only some
default swing focus transfer and there is no focus handling in wizard
or panel.
Comment 3 Peter Zavadsky 2003-11-13 13:44:26 UTC
It doesn't have to do anything with window system. During that time it
is not loaded yet.
Comment 4 Jiri Rechtacek 2004-01-11 13:25:32 UTC
Mariane, is this problem still valid? It looks ok for me (if I have
understood the description right. Could you try reproduce it? Thanks
Comment 5 Marian Mirilovic 2004-01-12 09:07:48 UTC
Jirka, 
Import Settings wizard is gone, so please close it, thanks in advance ;)
Comment 6 Jiri Rechtacek 2004-01-12 09:19:50 UTC
Import settings wizard was removed from NB (task 38552) => WONTFIX
Comment 7 Marian Mirilovic 2004-01-15 10:58:26 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo