Bug 32648 - treefs.nbm for NB 3.4.1 is improperly packaged
treefs.nbm for NB 3.4.1 is improperly packaged
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
3.x
All All
: P1 (vote)
: TBD
Assigned To: rnovak
nbbuild-issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-04 21:38 UTC by Jesse Glick
Modified: 2003-04-09 16:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-04-04 21:38:15 UTC
http://www.netbeans.org/download/nbms/34/treefs.nbm

in its Info/info.xml starts with:

<!DOCTYPE module PUBLIC "-//NetBeans//DTD
Autoupdate Module Info 2.0//EN"
"http://www.netbeans.org/dtds/autoupdate-info-2_0.dtd">

This is quite wrong; NB 3.4 did not support this
DTD (introduced in issue #22948). The 3.4 version
of treefs.nbm may not use that DTD. The 3.4
version of <makenbm> did not produce it, either.
That means someone was using a post-3.4 dev build
to create the NBM, which generally will not work.
It should be built from 3.4 sources:

cd .../r341/nb_all
ant -f nbbuild/build.xml all-treefs
ant -f treefs/build.xml nbm

The symptom: updating this module from AU can hang
the updater (hence the P1). You have to kill the
updater and manually delete the NBM before it will
stay dead. I am unable to reproduce the hang, but
it has been reported on nbusers and seems
plausible; at least the NBM format is definitely
wrong.
Comment 1 rnovak 2003-04-08 09:16:09 UTC
I'll fix it ASAP.
Comment 2 rnovak 2003-04-09 16:34:07 UTC
New NBM with DTD http://www.netbeans.org/dtds/autoupdate-info-1_0.dtd
was built and uploaded to the Beta UC for Netbeans 3.4.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo