Bug 32463 - Can not get emulated right click on multiple files
Can not get emulated right click on multiple files
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Explorer
3.x
Macintosh Mac OS X
: P3 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
APPLE_JDK_BUG
: JDK_SPECIFIC
: 33285 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-28 14:11 UTC by mschorer
Modified: 2008-12-22 13:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mschorer 2003-03-28 14:11:12 UTC
Happens on MAC OS X 10.2.4 with JDK 1.4.1.

I select multiple files, then I press the Meta (Apple) Key an then click the mouse to emulate a right click for menu.

Result:
All files are deselected except for the one which on which the mouse cursor is located. Any action selected in the menu works only for this file, not for all previously selected ones.

Expected Result:
Normally the menu should open and all files should still be selected. Any action in the menu should be applied to all selected files.
Comment 1 Tomas Hurka 2003-06-25 13:53:35 UTC
*** Issue 33285 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Hurka 2004-01-21 08:09:49 UTC
I found out that JTree does not retain its selection when control clicked. So it is an bug 
in JDK. I reported it to Apple including simple example. Bug ID is 3534423. Closing as 
wontfix.
Comment 3 Marian Mirilovic 2005-07-12 09:47:26 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo