Bug 32292 - Enable detection of FFJ and S1S
Enable detection of FFJ and S1S
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: Code
3.x
PC All
: P1 (vote)
: 3.x
Assigned To: Richard Gregor
issues@installer
:
: 32508 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-25 13:21 UTC by Richard Gregor
Modified: 2003-04-07 20:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Diff of changes commited in trunk (5.75 KB, patch)
2003-03-26 15:07 UTC, Richard Gregor
Details | Diff
diff of changes against trunk (591 bytes, patch)
2003-04-01 11:11 UTC, Richard Gregor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Gregor 2003-03-25 13:21:12 UTC
Enable detection of previously installed FFJ and
S1S. Users will be able to import settings not
only from previous NetBeans but those product as well.
Comment 1 Richard Gregor 2003-03-26 15:07:38 UTC
Created attachment 9536 [details]
Diff of changes commited in trunk
Comment 2 Richard Gregor 2003-03-26 15:09:54 UTC
Fixed in trunk. There are new methods called to search for S1S and FFJ
installation.
Comment 3 _ ttran 2003-03-28 15:23:04 UTC
still waiting for verification and code review
Comment 4 dmladek 2003-03-31 10:17:39 UTC
Please, stay tunned, I'm testing it right now.....
Comment 5 dmladek 2003-03-31 10:58:56 UTC
Well, I'm in process of testing and I met some small "unclearness":-(

(I took DEV installer from 28 MAR, 03).
It offers me from dropDownList only import from previous NB3.4

-Which I think is unclear if I'm allowed to import from others products
as well.
So, that coudl be a UI problem for an user.

For me, is unclear what version of FFJ and S1S do you mean?
So, It is hard to test if I don'y know on which versions :-/

-----
Anyway, for testing purposes I took FFJ4.01 Sierra settings.

Import wasn't  done successfuly:-((
Installation process screwed up my settings with installing SW into a
dir which I offered installer as my dir from which it has import!
NOT TO INSTALL!!! :-(((

I don't think it is reasonable behaviour and if I were a user I would
finished up with such dummy SW immediately:-(

OK. That was also partialy my mistake, 'cause I had read carefuly
that the next dir isn't dir which I though was for importing settings
from it.
But  still I think most user will have the same problem, and will hate
such installation :-(
Comment 6 dmladek 2003-03-31 11:10:18 UTC
I'm going to enter new issue for usability of installer....
Comment 7 dmladek 2003-03-31 11:52:06 UTC
This is realy strange UI behaviour for me and I don't realy understand 
what could I expect from the installator :-(

I'm gonna enter a new bug for Import settings what installer should do
OMHO.
This bug is related to detection of others versions.

I'd rather say AUTO-DETECTION ''cause it doesn't detect me anything
:-( ANd be sure I have installed other version on my computer.
(but I was told that only standard path are "auto"-detected, which is
"funny":-( )

So I'm going to install all those product to standard path
and let you know how it is able detect them :-)


Comment 8 Richard Gregor 2003-03-31 12:46:10 UTC
Dan, just to make things clear, I told you about standard userdir!
Probably standard path equals installdir in your comments - but it is
slighty different. You can install your IDE wherever you want, but use
standard userdir.I'm one of users who use standard userdir. 

Comment 9 dmladek 2003-03-31 15:39:36 UTC
Yeah, I meant standard path equals installdir and userdir.

You know I don't use either standard userdir nor installdir 'just
because of testing those stuffs and simply I can't have stored various
versions/backups in one standard userdir;-)

I'm still working on it...
Comment 10 Richard Gregor 2003-04-01 08:22:58 UTC
Daniel wrote:
>For me, is unclear what version of FFJ and S1S do you mean?
>So, It is hard to test if I don'y know on which versions :-/

Dan, I sent an email to you cca week ago with detailed description
about supported versions of FFj and S1S (sent date 03/27/2003 04:50 PM). 
New supported are CE of S1S4 upd1, FFJ4.0 a FFJ3.0

>OK. That was also partialy my mistake, 'cause I had read carefuly
>that the next dir isn't dir which I though was for importing
>settings from it.
>But  still I think most user will have the same problem, and will
>hate such installation :-(

You can believe me, I didn't see any comment of user that tried to put
his userdir as installdir except your.
Comment 11 Richard Gregor 2003-04-01 11:11:07 UTC
Created attachment 9623 [details]
diff of changes against trunk
Comment 12 Richard Gregor 2003-04-01 11:12:49 UTC
I have changed DetectAction to search for ffjuser40ce instead of
ffjuser40.

Checking in src/org/netbeans/installer/actions/DetectAction.java;
/cvs/installer/src/org/netbeans/installer/actions/DetectAction.java,v
 <--  DetectAction.java
new revision: 1.9; previous revision: 1.8
done
Comment 13 Tomas Pavek 2003-04-01 12:58:01 UTC
Both diffs look ok. If the fix work, I see no problem integrating it
to release35. Usability seems to be another issue, not affected by
this fix.
Comment 14 _ ttran 2003-04-01 14:02:10 UTC
approved by release coordinator for 3.5
Comment 15 dmladek 2003-04-02 14:47:27 UTC
Working on linux.
Testing on Win
Comment 16 Richard Gregor 2003-04-03 06:34:24 UTC
*** Issue 32508 has been marked as a duplicate of this issue. ***
Comment 17 Richard Gregor 2003-04-04 15:08:12 UTC
merged in release35
Comment 18 dmladek 2003-04-04 15:23:31 UTC
On Win XP it is OK
Comment 19 dmladek 2003-04-07 20:07:36 UTC
forgot to mark it as VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo