Bug 31827 - Enhance Code Completion by Documentation Hints
Enhance Code Completion by Documentation Hints
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: Code
3.x
All All
: P2 (vote)
: TBD
Assigned To: issues@xml
issues@xml
lines=6500 plan duration=15
: API, UI
: 28601 (view as bug list)
Depends on: 32557 32558 32559 32561
Blocks: 32047
  Show dependency treegraph
 
Reported: 2003-03-10 15:22 UTC by _ pkuzel
Modified: 2007-09-25 01:31 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ pkuzel 2003-03-10 15:22:28 UTC
Get inspired by java editor. It allows to show
instant help while querying for code completion.

Use similar approach as for GrammarQuery allowing
multiple documentation providers and multiple
documentation consumers (presenters) => xml/core.
Comment 1 Jesse Glick 2003-03-10 15:41:52 UTC
Should be useful for Ant module.
Comment 2 _ pkuzel 2003-03-14 19:38:18 UTC
*** Issue 28601 has been marked as a duplicate of this issue. ***
Comment 3 Jesse Glick 2003-07-08 15:24:17 UTC
To refresh my memory - this would be somehow similar to the Javadoc
popup, right?

I assume this would be an API enhancement? If so, consider adding the
'API' keyword.
Comment 4 _ pkuzel 2003-07-08 16:10:17 UTC
Adding API kw. It will form a framework so some public contract for
provders will be needed.
Comment 5 Mikhail Matveev 2007-09-24 15:55:09 UTC
Fixed long time ago
Comment 6 Mikhail Matveev 2007-09-24 15:56:12 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo