Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 31807 - One-click boolean editor is not possible in SheetButton
One-click boolean editor is not possible in SheetButton
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P3 (vote)
: TBD
Assigned To: _ tboudreau
issues@platform
:
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-09 21:33 UTC by Tim Lebedkov
Modified: 2008-12-22 18:56 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Lebedkov 2003-03-09 21:33:49 UTC
Hi,

it is impossible to create a one-click boolean editor 
(using a checkbox) for TreeTableView. Two clicks are 
necessary now.

Tim
Comment 1 Jiri Rechtacek 2003-03-13 11:15:55 UTC
It's a matter of SheetButton (which is used in TTV), preferably
enhancement.
I reassign to propertysheets.
I thought it was a duplicate of other issue but I was not able to find
it :)
Comment 2 _ tboudreau 2003-03-13 20:19:49 UTC
Adding to propsheet rewrite umbrella issue - it's already implemented
in a branch (which does not use SheetButton - that will be deprecated)
Comment 3 _ tboudreau 2003-06-25 23:55:12 UTC
Changing this issue to depend on issue 31896.  The new
property sheet uses a checkbox, but PropertyPanel (a UI
component for displaying a single property) still relies
on SheetButton for the time being.

The plan is to rewrite PropertyPanel to use the rendering
infrastructure from the new property sheet.  Probably this
will come after some revision of the current support for
properties - I tried a prototype, but it involved many
horrible hacks because PropertyPanel knows nothing about
Node.Property objects, only about PropertyModel, which 
doesn't provide all of the methods the propertysheet
rendering infrastructure needs.  Better to sort the 
mess out than hack further - the new propertysheet already
contains some hacks to abide by the rather worn and tired
existing API.
Comment 4 _ tboudreau 2003-11-16 11:32:15 UTC
Note that HIE has decreed that our boolean editor shall be a pair of
radio buttons - this will go in in the property panel rewrite branch
merge.

I will try to include some flexibility so that, e.g., a property panel
can specify that it prefers a checkbox.
Comment 5 _ tboudreau 2003-12-09 09:37:09 UTC
Property panel rewrite branch merged.
Comment 6 Tim Lebedkov 2004-09-28 20:05:38 UTC
ok


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo